angular_forms 4.0.1 copy "angular_forms: ^4.0.1" to clipboard
angular_forms: ^4.0.1 copied to clipboard

discontinuedreplaced by: ngforms
Platformweb

Forms framework for AngularDart.

9
likes
110/ 140
pub points
90%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

159 out of 289 API elements (55.0 %) have documentation comments.

Some symbols that are missing documentation: angular_forms.AbstractControl, angular_forms.AbstractControl.AbstractControl, angular_forms.AbstractControl.dirty, angular_forms.AbstractControl.disabled, angular_forms.AbstractControl.disabledChanges.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:angular_forms/angular_forms.dart that imports:
  • package:angular_forms/src/validators.dart that imports:
  • package:angular_forms/src/model.dart that imports:
  • package:angular_forms/src/directives/validators.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/testability.dart that imports:
  • package:angular/src/testability/testability.dart that imports:
  • package:angular/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform iOS

Because:

  • package:angular_forms/angular_forms.dart that imports:
  • package:angular_forms/src/validators.dart that imports:
  • package:angular_forms/src/model.dart that imports:
  • package:angular_forms/src/directives/validators.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/testability.dart that imports:
  • package:angular/src/testability/testability.dart that imports:
  • package:angular/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Windows

Because:

  • package:angular_forms/angular_forms.dart that imports:
  • package:angular_forms/src/validators.dart that imports:
  • package:angular_forms/src/model.dart that imports:
  • package:angular_forms/src/directives/validators.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/testability.dart that imports:
  • package:angular/src/testability/testability.dart that imports:
  • package:angular/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Linux

Because:

  • package:angular_forms/angular_forms.dart that imports:
  • package:angular_forms/src/validators.dart that imports:
  • package:angular_forms/src/model.dart that imports:
  • package:angular_forms/src/directives/validators.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/testability.dart that imports:
  • package:angular/src/testability/testability.dart that imports:
  • package:angular/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform macOS

Because:

  • package:angular_forms/angular_forms.dart that imports:
  • package:angular_forms/src/validators.dart that imports:
  • package:angular_forms/src/model.dart that imports:
  • package:angular_forms/src/directives/validators.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/testability.dart that imports:
  • package:angular/src/testability/testability.dart that imports:
  • package:angular/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: 'NgControlStatus' is deprecated and shouldn't be used. Use listeners or variable binding on the control itself instead. This adds overhead for every form control whether the class is used or not.

lib/angular_forms.dart:33:9

   ╷
33 │         NgControlStatus,
   │         ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/angular_forms.dart

INFO: 'NgControlStatus' is deprecated and shouldn't be used. Use listeners or variable binding on the control itself instead. This adds overhead for every form control whether the class is used or not.

lib/src/directives.dart:36:49

   ╷
36 │ export 'directives/ng_control_status.dart' show NgControlStatus;
   │                                                 ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/directives.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
angular ^7.0.0 7.0.2 7.0.2
meta ^1.3.0 1.14.0 1.14.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 31.0.0 67.0.0
analyzer - 2.8.0 6.4.1
angular_ast - 2.0.1 2.0.1
angular_compiler - 2.0.2 2.0.2
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
build_resolvers - 2.0.6 2.4.2
build_test - 2.2.0 2.2.2
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
charcode - 1.3.1 1.3.1
checked_yaml - 2.0.3 2.0.3
cli_util - 0.3.5 0.4.1
clock - 1.1.1 1.1.1
code_builder - 4.10.0 4.10.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
coverage - 1.3.2 1.7.2
crypto - 3.0.3 3.0.3
csslib - 0.17.3 1.0.0
dart_style - 2.2.1 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
frontend_server_client - 2.1.3 4.0.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
html - 0.15.4 0.15.4
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
intl - 0.17.0 0.19.0
io - 1.0.4 1.0.4
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
matcher - 0.12.11 0.12.16+1
mime - 1.0.5 1.0.5
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pedantic - 1.11.1 1.11.1
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
quiver - 3.2.1 3.2.1
shelf - 1.4.1 1.4.1
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 1.0.4
source_gen - 1.2.2 1.5.0
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test - 1.20.2 1.25.3
test_api - 0.4.9 0.7.1
test_core - 0.4.11 0.6.1
typed_data - 1.3.2 1.3.2
vm_service - 8.3.0 14.2.0
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 2.4.5
webkit_inspection_protocol - 1.2.1 1.2.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.