angular_bloc 9.0.0 copy "angular_bloc: ^9.0.0" to clipboard
angular_bloc: ^9.0.0 copied to clipboard

Platformweb

Angular Components that make it easy to implement the BLoC (Business Logic Component) design pattern. Built to be used with the bloc state management package.

36
likes
140/ 140
pub points
78%
popularity

We analyzed this package 18 hours ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/felangel/bloc/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

71 out of 71 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:angular_bloc/angular_bloc.dart that imports:
  • package:angular_bloc/src/pipes/pipes.dart that imports:
  • package:angular_bloc/src/pipes/bloc_pipe.dart that imports:
  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform iOS

Because:

  • package:angular_bloc/angular_bloc.dart that imports:
  • package:angular_bloc/src/pipes/pipes.dart that imports:
  • package:angular_bloc/src/pipes/bloc_pipe.dart that imports:
  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Windows

Because:

  • package:angular_bloc/angular_bloc.dart that imports:
  • package:angular_bloc/src/pipes/pipes.dart that imports:
  • package:angular_bloc/src/pipes/bloc_pipe.dart that imports:
  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Linux

Because:

  • package:angular_bloc/angular_bloc.dart that imports:
  • package:angular_bloc/src/pipes/pipes.dart that imports:
  • package:angular_bloc/src/pipes/bloc_pipe.dart that imports:
  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform macOS

Because:

  • package:angular_bloc/angular_bloc.dart that imports:
  • package:angular_bloc/src/pipes/pipes.dart that imports:
  • package:angular_bloc/src/pipes/bloc_pipe.dart that imports:
  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc ^8.0.0 8.1.4 8.1.4
ngdart ^7.0.0 7.1.1 7.1.1
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 47.0.0 68.0.0
analyzer - 4.7.0 6.5.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
build_resolvers - 2.0.10 2.4.2
build_test - 2.2.0 2.2.2
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
charcode - 1.3.1 1.3.1
checked_yaml - 2.0.3 2.0.3
clock - 1.1.1 1.1.1
code_builder - 4.10.0 4.10.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
coverage - 1.6.4 1.8.0
crypto - 3.0.3 3.0.3
csslib - 0.17.3 1.0.0
dart_style - 2.2.4 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
frontend_server_client - 3.2.0 4.0.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
html - 0.15.4 0.15.4
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
intl - 0.17.0 0.19.0
io - 1.0.4 1.0.4
js - 0.6.7 0.7.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
mime - 1.0.5 1.0.5
ngast - 2.1.4 2.1.4
ngcompiler - 2.1.3 2.1.3
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
quiver - 3.2.1 3.2.1
shelf - 1.4.1 1.4.1
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
source_gen - 1.2.6 1.5.0
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test - 1.24.3 1.25.5
test_api - 0.6.0 0.7.1
test_core - 0.5.3 0.6.2
typed_data - 1.3.2 1.3.2
vm_service - 11.10.0 14.2.2
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
webkit_inspection_protocol - 1.2.1 1.2.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

36
likes
140
pub points
78%
popularity
screenshot

Publisher

verified publisherbloclibrary.dev

Angular Components that make it easy to implement the BLoC (Business Logic Component) design pattern. Built to be used with the bloc state management package.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

bloc, ngdart

More

Packages that depend on angular_bloc