angular_bloc 4.0.0

Dart native js
Flutter Android iOS web

Angular Components that make it easy to implement the BLoC (Business Logic Component) design pattern. Built to be used with the bloc state management package.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  angular_bloc: ^4.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angular_bloc/angular_bloc.dart';
11
likes
95
pub points
83%
popularity

Publisher

bloclibrary.dev

Angular Components that make it easy to implement the BLoC (Business Logic Component) design pattern. Built to be used with the bloc state management package.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angular, bloc

More

Packages that depend on angular_bloc