amplify_secure_storage 0.4.2 copy "amplify_secure_storage: ^0.4.2" to clipboard
amplify_secure_storage: ^0.4.2 copied to clipboard

A package for storing secrets, intended for use in Amplify libraries.

2
likes
140/ 140
pub points
76%
popularity

We analyzed this package 3 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

119 out of 153 API elements (77.8 %) have documentation comments.

Some symbols that are missing documentation: amplify_secure_storage, amplify_secure_storage.AmplifySecureStorageConfig.copyWith, amplify_secure_storage.AmplifySecureStorageConfig.namespace, amplify_secure_storage.AmplifySecureStorageConfigBuilder, amplify_secure_storage.AmplifySecureStorageConfigBuilder.AmplifySecureStorageConfigBuilder.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/utils/file_key_value_store.dart that declares support for platforms: iOS, Windows, Linux, macOS, Web.
Package does not support platform `iOS`.

Because:

  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/amplify_secure_storage_dart.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/platforms/amplify_secure_storage_windows.dart that imports:
  • package:amplify_secure_storage_dart/src/ffi/win32/data_protection.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/amplify_secure_storage_dart.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/platforms/amplify_secure_storage_windows.dart that imports:
  • package:amplify_secure_storage_dart/src/ffi/win32/data_protection.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/amplify_secure_storage_dart.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/platforms/amplify_secure_storage_windows.dart that imports:
  • package:amplify_secure_storage_dart/src/ffi/win32/data_protection.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
amplify_secure_storage_dart >=0.4.3 <0.5.0 0.4.3 0.4.3
async ^2.10.0 2.11.0 2.11.0
file >=6.0.0 <8.0.0 7.0.0 7.0.0
flutter flutter 0.0.0 0.0.0
meta ^1.7.0 1.11.0 1.12.0
path >=1.8.0 <2.0.0 1.9.0 1.9.0
path_provider ^2.0.0 2.1.2 2.1.2
path_provider_windows ^2.0.0 2.2.1 2.2.1
Transitive dependencies
Package Constraint Compatible Latest
aws_common - 0.6.3 0.6.3
built_collection - 5.1.1 5.1.1
built_value - 8.8.1 8.9.1
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
fixnum - 1.1.0 1.1.0
http2 - 2.3.0 2.3.0
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.8.0
mime - 1.0.5 1.0.5
os_detect - 2.0.1 2.0.1
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
typed_data - 1.3.2 1.3.2
uuid - 4.3.3 4.3.3
vector_math - 2.1.4 2.1.4
win32 - 5.2.0 5.2.0
worker_bee - 0.2.3 0.2.3
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.