advance_image_picker 0.1.7+1 copy "advance_image_picker: ^0.1.7+1" to clipboard
advance_image_picker: ^0.1.7+1 copied to clipboard

Flutter plugin in pure Dart code for selecting/editing multiple images from the Android/iOS image library and taking new pictures with the camera in the same view.

121
likes
80/ 140
pub points
79%
popularity

We analyzed this package 32 hours ago, and awarded it 80 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://freemar.vn was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

203 out of 217 API elements (93.5 %) have documentation comments.

Some symbols that are missing documentation: custom_track_shape, editor_params, image_edit, image_filter, image_object.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:advance_image_picker/advance_image_picker.dart that imports:
  • package:advance_image_picker/widgets/picker/image_picker.dart that imports:
  • package:advance_image_picker/widgets/picker/media_album.dart that imports:
  • package:advance_image_picker/utils/image_utils.dart that imports:
  • package:photo_manager/photo_manager.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:advance_image_picker/advance_image_picker.dart that imports:
  • package:advance_image_picker/widgets/picker/image_picker.dart that imports:
  • package:advance_image_picker/widgets/picker/media_album.dart that imports:
  • package:advance_image_picker/utils/image_utils.dart that imports:
  • package:photo_manager/photo_manager.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:advance_image_picker/advance_image_picker.dart that imports:
  • package:advance_image_picker/widgets/picker/image_picker.dart that imports:
  • package:advance_image_picker/widgets/picker/media_album.dart that imports:
  • package:advance_image_picker/utils/image_utils.dart that imports:
  • package:flutter_native_image/flutter_native_image.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:advance_image_picker/advance_image_picker.dart that imports:
  • package:advance_image_picker/widgets/picker/image_picker.dart that imports:
  • package:advance_image_picker/widgets/picker/media_album.dart that imports:
  • package:advance_image_picker/utils/image_utils.dart that imports:
  • package:photo_manager/photo_manager.dart that declares support for platforms: Android, iOS, macOS.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 22 issues. Showing the first 2:

ERROR: The named parameter 'primary' isn't defined.

lib/widgets/picker/image_picker.dart:428:25

    ╷
428 │                         primary: Colors.black87,
    │                         ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/widgets/picker/image_picker.dart

ERROR: The named parameter 'primary' isn't defined.

lib/widgets/picker/image_picker.dart:440:25

    ╷
440 │                         primary: Colors.black87,
    │                         ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/widgets/picker/image_picker.dart

OK
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
camera ^0.9.7+1 0.9.8+1 0.10.5+9
flutter flutter 0.0.0 0.0.0
flutter_native_image ^0.0.6+1 0.0.6+1 0.0.6+1
image ^3.1.3 3.3.0 4.1.7
image_cropper ^2.0.0 2.0.3 5.0.1
image_editor ^1.0.2 1.4.0 1.4.0
path_provider ^2.0.10 2.1.3 2.1.3
photo_manager ^2.1.2 2.8.2 3.0.0
photo_view ^0.14.0 0.14.0 0.15.0
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
camera_android - 0.9.8+3 0.10.9+1
camera_avfoundation - 0.9.15+4 0.9.15+4
camera_platform_interface - 2.7.4 2.7.4
camera_web - 0.2.1+6 0.3.3
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
cross_file - 0.3.4+1 0.3.4+1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
flutter_plugin_android_lifecycle - 2.0.19 2.0.19
flutter_web_plugins - 0.0.0 0.0.0
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
image_cropper_for_web - 0.0.4 3.0.0
image_cropper_platform_interface - 2.0.0 5.0.0
image_editor_common - 1.0.1 1.0.1
image_editor_ohos - 0.0.7 0.0.7
image_editor_platform_interface - 1.0.1 1.0.1
js - 0.6.7 0.7.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.9.0 3.9.0
quiver - 3.2.1 3.2.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.9.7+1` on camera does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions camera to update the constraint.

The constraint `^3.1.3` on image does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

121
likes
80
pub points
79%
popularity

Publisher

verified publisherweta.vn

Flutter plugin in pure Dart code for selecting/editing multiple images from the Android/iOS image library and taking new pictures with the camera in the same view.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

camera, flutter, flutter_native_image, image, image_cropper, image_editor, path_provider, photo_manager, photo_view

More

Packages that depend on advance_image_picker