ac_core 0.1.0 copy "ac_core: ^0.1.0" to clipboard
ac_core: ^0.1.0 copied to clipboard

Core package for my flutter apps

0
likes
110/ 140
pub points
0%
popularity

We analyzed this package 19 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://core.aravi.me/flutter was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: GPL-3.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 3 API elements (66.7 %) have documentation comments.

Some symbols that are missing documentation: ac_core.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
battery_plus ^3.0.2 3.0.6 5.0.3
built_collection ^5.1.1 5.1.1 5.1.1
cached_network_image ^3.2.2 3.3.1 3.3.1
flutter flutter 0.0.0 0.0.0
flutter_secure_storage ^6.0.0 6.1.0 9.0.0
get ^4.6.5 4.6.6 4.6.6
google_fonts ^3.0.1 3.0.1 6.2.0
hive ^2.2.3 2.2.3 2.2.3
intl ^0.17.0 0.17.0 0.19.0
json_serializable ^6.5.4 6.7.1 6.7.1
logger ^1.1.0 1.4.0 2.1.0
path_provider ^2.0.11 2.1.2 2.1.2
riverpod ^2.1.1 2.5.0 2.5.0
shared_preferences ^2.0.15 2.2.2 2.2.2
url_launcher ^6.1.6 6.2.5 6.2.5
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
battery_plus_platform_interface - 1.2.2 2.0.0
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
cached_network_image_platform_interface - 4.0.0 4.0.0
cached_network_image_web - 1.1.1 1.1.1
characters - 1.3.0 1.3.0
checked_yaml - 2.0.3 2.0.3
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_cache_manager - 3.3.1 3.3.1
flutter_secure_storage_linux - 1.2.0 1.2.0
flutter_secure_storage_macos - 1.1.2 3.0.1
flutter_secure_storage_platform_interface - 1.0.2 1.0.2
flutter_secure_storage_web - 1.1.2 1.1.2
flutter_secure_storage_windows - 1.1.3 3.0.0
flutter_web_plugins - 0.0.0 0.0.0
glob - 2.1.2 2.1.2
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
octo_image - 2.0.0 2.0.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
rxdart - 0.27.7 0.27.7
shared_preferences_android - 2.2.1 2.2.1
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_gen - 1.5.0 1.5.0
source_helper - 1.3.4 1.3.4
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite - 2.3.2 2.3.2
sqflite_common - 2.5.3 2.5.3
stack_trace - 1.11.1 1.11.1
state_notifier - 1.0.0 1.0.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
upower - 0.7.0 0.7.0
url_launcher_android - 6.3.0 6.3.0
url_launcher_ios - 6.2.5 6.2.5
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.0 2.3.0
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.3.3 4.3.3
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^3.0.2` on battery_plus does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions battery_plus to update the constraint.

The constraint `^6.0.0` on flutter_secure_storage does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions flutter_secure_storage to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.