z_components 0.9.35+29
z_components: ^0.9.35+29 copied to clipboard

Z_Components is a package that contains a set of standardized components to facilitate, optimize, and accelerate the development of Zellar company's Android / IOS applications.

4
likes
70 / 130
pub points
60 %
popularity

We analyzed this package on Jun 19, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 152 out of 3476 API elements (4.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:z_components/api/api-settings.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 101 issues. Showing the first 2:

lib/api/api-settings.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/api/arquivo/arquivo-service.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
after_init^0.1.20.1.20.1.2
after_layout^1.0.7+21.1.01.1.0
brasil_fields^1.0.01.1.31.1.3
cached_network_image^2.0.02.3.33.0.0
chewie^0.9.100.9.101.2.2
circular_check_box^1.0.11.0.41.0.4
configurable_expansion_tile^1.0.01.0.01.0.0
cpf_cnpj_validator^1.0.51.0.52.0.0
crypto^2.1.52.1.53.0.1
dio^3.0.93.0.104.0.0
email_validator^1.0.01.0.62.0.1
flutterflutter0.0.00.0.0
flutter_cache_manager^1.4.11.4.23.1.2
flutter_circular_chart^0.1.00.1.00.1.0
flutter_datetime_picker^1.5.11.5.11.5.1
flutter_genius_scan^3.0.273.0.274.0.8
flutter_image_compress^0.7.00.7.01.0.0
flutter_localizationsflutter0.0.00.0.0
flutter_spinkit^4.1.24.1.2+15.0.0
flutter_svg^0.19.30.19.30.22.0
flutter_webview_plugin^0.3.10+10.3.110.4.0
http^0.12.0+10.12.20.13.3
image_picker^0.6.3+40.6.7+220.8.0+3
injector^1.0.81.0.92.0.0
intl^0.17.00.17.00.17.0
mask_shifter^0.1.00.1.00.1.0
mask_text_input_formatter^1.2.11.2.12.0.0
meta^1.1.81.3.01.4.0
open_file^2.0.32.1.13.2.1
path^1.6.41.8.01.8.0
path_provider^1.6.51.6.282.0.2
percent_indicator^2.1.1+12.1.9+13.0.1
pin_code_text_field^1.5.01.8.01.8.0
provider^2.0.12.0.1+15.0.0
pull_to_refresh^1.5.71.6.52.0.0
randombytes^0.1.10.1.10.1.1
shared_preferences^0.5.12+40.5.12+42.0.6
shimmer^1.0.11.1.22.0.0
sqflite^1.1.6+41.3.2+42.0.0+3
table_calendar^2.2.32.3.33.0.0
url_launcher^5.4.25.7.106.0.6
uuid^2.0.42.2.23.0.4
video_player^0.10.8+10.10.12+52.1.6
video_thumbnail^0.2.00.2.5+10.3.3
youtube_player_flutter^6.1.0+46.1.18.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.6.12.7.0
boolean_selector-2.1.02.1.0
characters-1.1.01.1.0
charcode-1.2.01.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
fake_async-1.2.01.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.5.00.6.0
flutter_plugin_android_lifecycle-1.0.112.0.2
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
image_picker_platform_interface-1.1.62.1.0
js-0.6.30.6.3
matcher-0.12.100.12.10
octo_image-0.3.01.0.0+1
open_iconic_flutter-0.3.00.3.0
path_drawing-0.4.1+10.5.1
path_parsing-0.1.40.2.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
pedantic-1.11.11.11.1
petitparser-3.1.04.2.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
rxdart-0.24.10.27.1
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
simple_gesture_detector-0.1.60.2.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-1.0.3+32.0.0+2
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
test_api-0.3.00.4.1
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.3
url_launcher_web-0.1.5+32.0.1
url_launcher_windows-0.0.1+32.0.0
vector_math-2.1.02.1.0
video_player_platform_interface-2.2.04.1.0
video_player_web-0.1.4+12.0.1
wakelock-0.1.4+20.5.2
webview_media-0.1.20.1.2
win32-2.2.02.2.0
xdg_directories-0.1.20.2.0
xml-4.5.15.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 30 issues. Showing the first 2:

The constraint `^2.0.0` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^0.9.10` on chewie does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions chewie to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.