z_components 0.9.40+13 icon indicating copy to clipboard operation
z_components: ^0.9.40+13 copied to clipboard

Z_Components is a package that contains a set of standardized components to facilitate, optimize, and accelerate the development of Zellar company's Android / IOS applications.

6
likes
60/ 130
pub points
45%
popularity

We analyzed this package 19 hours ago, and awarded it 60 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 210 out of 4891 API elements (4.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:z_components/api/api-settings.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:z_components/api/api-settings.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:z_components/api/api-settings.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:z_components/api/api-settings.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:z_components/api/arquivo/arquivo-service.dart that imports:
  • package:z_components/api/service.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:z_components/api/arquivo/arquivo-service.dart that imports:
  • package:z_components/api/service.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 654 issues. Showing the first 2:

ERROR: The method 'BlacklistingTextInputFormatter' isn't defined for the type 'ZBaseLineState'.

lib/components/z-baseline.dart:167:29

    ╷
167 │                             BlacklistingTextInputFormatter(RegExp("[\\\\/,.]")),
    │                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/components/z-baseline.dart

ERROR: The method 'BlacklistingTextInputFormatter' isn't defined for the type 'ZBaseLineState'.

lib/components/z-baseline.dart:301:29

    ╷
301 │                             BlacklistingTextInputFormatter(RegExp("[\\\\,.]")),
    │                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/components/z-baseline.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
after_init^0.1.20.1.20.1.2
after_layout^1.0.7+21.2.01.2.0
brasil_fields^1.0.01.4.51.4.5
cached_network_image^2.0.02.3.33.2.1
chewie^0.9.100.9.101.3.4
circular_check_box^1.0.11.0.41.0.4
configurable_expansion_tile^1.0.01.0.01.0.0
cpf_cnpj_validator^1.0.51.0.52.0.0
crypto^2.1.52.1.53.0.2
dio^3.0.93.0.104.0.6
email_validator^1.0.01.0.62.1.17
flutterflutter0.0.00.0.0
flutter_bloc^7.0.17.3.38.0.1
flutter_cache_manager^1.4.11.4.23.3.0
flutter_circular_chart^0.1.00.1.00.1.0
flutter_colorpicker^0.3.40.3.51.0.3
flutter_datetime_picker^1.5.11.5.11.5.1
flutter_genius_scan^3.0.273.0.274.5.2
flutter_image_compress^0.7.00.7.01.1.1
flutter_localizationsflutter0.0.00.0.0
flutter_spinkit^4.1.24.1.2+15.1.0
flutter_svg^0.19.30.19.31.1.3
flutter_treeview^1.0.4+11.0.7+11.0.7+1
flutter_webview_plugin^0.3.10+10.3.110.4.0
geocoder^0.2.10.2.10.2.1
google_maps_flutter^0.5.11+10.5.332.1.10
http^0.12.0+10.12.20.13.5
image_picker^0.6.3+40.6.7+220.8.5+3
injector^2.0.02.0.02.0.0
intl^0.17.00.17.00.17.0
mask_shifter^0.1.00.1.00.1.0
mask_text_input_formatter^2.0.02.4.02.4.0
meta^1.1.81.7.01.8.0
open_file^2.0.32.1.13.2.1
path^1.6.41.8.11.8.2
path_provider^1.6.51.6.282.0.11
percent_indicator^2.1.1+12.1.9+14.2.2
pin_code_text_field^1.5.01.8.01.8.0
pull_to_refresh^1.6.41.6.52.0.0
randombytes^0.1.10.1.10.1.1
shared_preferences^0.5.12+40.5.12+42.0.15
shimmer^1.0.11.1.22.0.0
sqflite^1.1.6+41.3.2+42.0.3+1
table_calendar^2.2.32.3.33.0.6
url_launcher^5.4.25.7.106.1.5
uuid^2.0.42.2.23.0.6
video_player^0.10.8+10.10.12+52.4.6
video_thumbnail^0.2.00.2.5+10.5.2
youtube_player_flutter^6.1.0+46.1.18.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.9.0
bloc-7.2.18.1.0
boolean_selector-2.1.02.1.0
characters-1.2.01.2.1
charcode-1.3.11.3.1
clock-1.1.01.1.1
collection-1.16.01.16.0
convert-2.1.13.0.2
fake_async-1.3.01.3.1
ffi-1.2.12.0.1
file-6.1.26.1.2
flutter_blurhash-0.5.00.7.0
flutter_plugin_android_lifecycle-1.0.112.0.7
flutter_test-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
google_maps_flutter_platform_interface-1.2.02.2.1
http_parser-3.1.44.0.1
image_picker_platform_interface-1.1.62.6.1
js-0.6.40.6.4
matcher-0.12.110.12.12
material_color_utilities-0.1.40.2.0
nested-1.0.01.0.0
octo_image-0.3.01.0.2
open_iconic_flutter-0.3.00.3.0
path_drawing-0.4.1+11.0.1
path_parsing-0.1.41.0.1
path_provider_linux-0.0.1+22.1.7
path_provider_macos-0.0.4+82.0.6
path_provider_platform_interface-1.0.42.0.4
path_provider_windows-0.0.52.1.2
pedantic-1.11.11.11.1
petitparser-3.1.05.0.0
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
provider-6.0.36.0.3
rxdart-0.24.10.27.5
shared_preferences_linux-0.0.2+42.1.1
shared_preferences_macos-0.0.1+112.0.4
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.4
shared_preferences_windows-0.0.2+32.1.1
simple_gesture_detector-0.1.60.2.0
sky_engine-0.0.990.0.99
source_span-1.8.21.9.1
sqflite_common-1.0.3+32.2.1+1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-1.2.02.0.0
string_scanner-1.1.01.1.1
synchronized-2.2.0+23.0.0+2
term_glyph-1.2.01.2.1
test_api-0.4.90.4.12
typed_data-1.3.11.3.1
url_launcher_linux-0.0.1+43.0.1
url_launcher_macos-0.0.1+93.0.1
url_launcher_platform_interface-1.0.92.1.0
url_launcher_web-0.1.5+32.0.13
url_launcher_windows-0.0.1+33.0.1
vector_math-2.1.22.1.2
video_player_platform_interface-2.2.05.1.4
video_player_web-0.1.4+12.0.12
wakelock-0.1.4+20.6.2
webview_media-0.1.20.1.2
win32-2.6.12.7.0
xdg_directories-0.1.20.2.0+1
xml-4.5.16.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 30 issues. Showing the first 2:

The constraint `^2.0.0` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^0.9.10` on chewie does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions chewie to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.15, Flutter 3.0.5, Dart 2.17.6.