geocoder 0.2.1

geocoder #

Forward and reverse geocoding.

Usage #

Import package:geocoder/geocoder.dart, and use the Geocoder.local to access geocoding services provided by the device system.

Example:

import 'package:geocoder/geocoder.dart';

// From a query
final query = "1600 Amphiteatre Parkway, Mountain View";
var addresses = await Geocoder.local.findAddressesFromQuery(query);
var first = addresses.first;
print("${first.featureName} : ${first.coordinates}");

// From coordinates
final coordinates = new Coordinates(1.10, 45.50);
addresses = await Geocoder.local.findAddressesFromCoordinates(coordinates);
first = addresses.first;
print("${first.featureName} : ${first.addressLine}");

You can alternatively use Geocoder.google member for requesting distant data from google services instead of native ones.

You will find links to the API docs on the pub page.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

[0.2.1] - Fixed issues with Uint8List

  • Fixed breaking changes in newer SDK versions.

[0.2.0] - Migration to AndroidX and fixes

  • Fixed multi-threading issues
  • Added language support to Google geocoder
  • Support for AndroidX

[0.1.0] - Initial

  • Initial version

example/README.md

geocoder_example #

Demonstrates how to use the geocoder plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  geocoder: ^0.2.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:geocoder/geocoder.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
97
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
93
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/geocoder.dart.

Run flutter format to format lib/geocoder.dart.

Format lib/model.dart.

Run flutter format to format lib/model.dart.

Format lib/services/base.dart.

Run flutter format to format lib/services/base.dart.

Format lib/services/distant_google.dart.

Run flutter format to format lib/services/distant_google.dart.

Format lib/services/local.dart.

Run flutter format to format lib/services/local.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (meta).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
meta ^1.1.6 1.1.6 1.1.7
Transitive dependencies
collection 1.14.11
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8

Admin