wiredash 2.1.2 copy "wiredash: ^2.1.2" to clipboard
wiredash: ^2.1.2 copied to clipboard

Wiredash is an interactive user feedback tool for Flutter apps including Promoter Score.

275
likes
140/ 140
pub points
94%
popularity

We analyzed this package 6 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: AAL.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

975 out of 1111 API elements (87.8 %) have documentation comments.

Some symbols that are missing documentation: wiredash, wiredash.ConfidentialMode, wiredash.ConfidentialMode.ConfidentialMode, wiredash.CustomizableWiredashMetaData.copyWith, wiredash.DeviceClass.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:wiredash/wiredash.dart that imports:
  • package:wiredash/src/core/wiredash_widget.dart that imports:
  • package:wiredash/src/feedback/feedback_backdrop.dart that imports:
  • package:wiredash/src/_wiredash_ui.dart that imports:
  • package:wiredash/src/core/widgets/backdrop/wiredash_backdrop.dart that imports:
  • package:wiredash/src/core/wiredash_model_provider.dart that imports:
  • package:wiredash/src/core/wiredash_model.dart that imports:
  • package:wiredash/src/metadata/meta_data_collector.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:wiredash/wiredash.dart that imports:
  • package:wiredash/src/core/wiredash_widget.dart that imports:
  • package:wiredash/src/feedback/feedback_backdrop.dart that imports:
  • package:wiredash/src/_wiredash_ui.dart that imports:
  • package:wiredash/src/core/widgets/backdrop/wiredash_backdrop.dart that imports:
  • package:wiredash/src/core/wiredash_model_provider.dart that imports:
  • package:wiredash/src/core/wiredash_model.dart that imports:
  • package:wiredash/src/metadata/meta_data_collector.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:wiredash/wiredash.dart that imports:
  • package:wiredash/src/core/wiredash_widget.dart that imports:
  • package:wiredash/src/feedback/feedback_backdrop.dart that imports:
  • package:wiredash/src/_wiredash_ui.dart that imports:
  • package:wiredash/src/core/widgets/backdrop/wiredash_backdrop.dart that imports:
  • package:wiredash/src/core/wiredash_model_provider.dart that imports:
  • package:wiredash/src/core/wiredash_model.dart that imports:
  • package:wiredash/src/metadata/meta_data_collector.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:wiredash/wiredash.dart that imports:
  • package:wiredash/src/core/wiredash_widget.dart that imports:
  • package:wiredash/src/feedback/feedback_backdrop.dart that imports:
  • package:wiredash/src/_wiredash_ui.dart that imports:
  • package:wiredash/src/core/widgets/backdrop/wiredash_backdrop.dart that imports:
  • package:wiredash/src/core/wiredash_model_provider.dart that imports:
  • package:wiredash/src/core/wiredash_model.dart that imports:
  • package:wiredash/src/metadata/meta_data_collector.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:wiredash/wiredash.dart that imports:
  • package:wiredash/src/core/wiredash_widget.dart that imports:
  • package:wiredash/src/feedback/feedback_backdrop.dart that imports:
  • package:wiredash/src/_wiredash_ui.dart that imports:
  • package:wiredash/src/core/widgets/backdrop/wiredash_backdrop.dart that imports:
  • package:wiredash/src/core/wiredash_model_provider.dart that imports:
  • package:wiredash/src/core/wiredash_model.dart that imports:
  • package:wiredash/src/metadata/meta_data_collector.dart that imports:
  • package:wiredash/src/_wiredash_internal.dart that imports:
  • package:wiredash/src/core/services/services.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.0.0 2.11.0 2.11.0
clock ^1.1.0 1.1.1 1.1.1
collection >=1.15.0 <2.0.0 1.18.0 1.18.0
device_info_plus >=8.0.0 <11.0.0 10.1.0 10.1.0
file >=6.0.0 <8.0.0 7.0.0 7.0.0
flutter flutter 0.0.0 0.0.0
flutter_localizations flutter 0.0.0 0.0.0
http >=0.13.0 <2.0.0 1.2.1 1.2.1
http_parser >=4.0.0 <5.0.0 4.0.2 4.0.2
intl >=0.16.0 <2.0.0 0.19.0 0.19.0
material_color_utilities >=0.1.2 <1.0.0 0.8.0 0.11.1
nanoid2 ^2.0.1 2.0.1 2.0.1
package_info_plus >=3.0.0 <9.0.0 8.0.0 8.0.0
path_provider >=2.0.0 <3.0.0 2.1.3 2.1.3
platform >=3.1.0 <5.0.0 3.1.4 3.1.4
shared_preferences >=2.0.0 <3.0.0 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
meta - 1.12.0 1.15.0
package_info_plus_platform_interface - 3.0.0 3.0.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.