vais_speech 1.0.8
vais_speech: ^1.0.8

Flutter Android

A new Flutter plugin.

2
likes
50 / 110
pub points
26 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:
  warning: vais_speech has no library level documentation comments, from vais_speech: (file:///tmp/pub-dartlang-dartdocHOGTOI/pkg/lib/vais.dart:1:9)
  error: failed to write file at: vais_speech/vais_speech-library.html
    for symbol vais_speech: (file:///tmp/pub-dartlang-dartdocHOGTOI/pkg/lib/vais_speech.dart:1:1)
    conflicting with file already generated by vais_speech: (file:///tmp/pub-dartlang-dartdocHOGTOI/pkg/lib/vais.dart:1:9)
            Dartdoc generates a path and filename to write to for each symbol.
            vais_speech conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
  warning: unresolved doc reference [speechText], from vais_speech_audio.VaisSpeechAudio.addListener: (file:///tmp/pub-dartlang-dartdocHOGTOI/pkg/lib/vais_speech_audio.dart:126:8)
  warning: unresolved doc reference [onConnection], from vais_speech_audio.VaisSpeechAudio.addListener: (file:///tmp/pub-dartlang-dartdocHOGTOI/pkg/lib/vais_speech_audio.dart:126:8)
  warning: unresolved doc reference [Paused], from vais_speech_audio.VaisSpeechAudio.pause: (file:///tmp/pub-dartlang-dartdocHOGTOI/pkg/lib/vais_speech_audio.dart:253:10)
  warning: unresolved doc reference [Paused], from vais_speech_audio.VaisSpeechAudio.resume: (file:///tmp/pub-dartlang-dartdocHOGTOI/pkg/lib/vais_speech_audio.dart:263:10)
  warning: unresolved doc reference [started], from vais_speech_audio.VaisSpeechAudio.start: (file:///tmp/pub-dartlang-dartdocHOGTOI/pkg/lib/vais_speech_audio.dart:141:10)
found 6 warnings and 1 error
Unhandled exception:
dartdoc encountered 1 errors while processing.
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:231:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:32:33)
<asynchronous suspension>
#2      _startIsolate.<anonymous closure> (dart:isolate-patch/isolate_patch.dart:299:32)
#3      _RawReceivePortImpl._handleMessage (dart:isolate-patch/isolate_patch.dart:168:12)
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform iOS

Because:

  • package:vais_speech/vais_speech.dart that declares support for platforms: Android
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 55 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/controller/streaming_controller.dart:15:14

   ╷
15 │   static int frame_size = Platform.isAndroid ? 1280 : 3200;
   │              ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/controller/streaming_controller.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/controller/streaming_controller.dart:16:17

   ╷
16 │   static double frame_duration = (( frame_size / 640) * 0.02);
   │                 ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/controller/streaming_controller.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
byte_array^0.1.60.1.60.1.6
file^5.0.45.2.15.2.1
fixnum^0.10.110.10.110.10.11
grpc^2.1.32.8.02.8.0
http^0.12.0+40.12.20.12.2
json_annotation^3.0.03.1.13.1.1
path^1.5.11.7.01.8.0-nullsafety.3
path_provider^1.6.181.6.241.6.24
protobuf^1.0.11.1.01.1.0
quiver^2.1.32.1.52.1.5
wakelock^0.1.4+20.1.4+20.2.1+1
web_socket_channel^1.1.01.1.01.1.0
xml^3.5.03.7.04.5.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.5.0-nullsafety.3
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
ffi-0.1.30.1.3
googleapis_auth-0.2.120.2.12
http2-1.0.11.0.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
matcher-0.12.90.12.10-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+60.0.4+6
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
source_span-1.7.01.8.0-nullsafety.4
stack_trace-1.9.61.10.0-nullsafety.6
stream_channel-2.0.02.1.0-nullsafety.3
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.4+2` on wakelock does not support the latest published version `0.2.1+1`

pubspec.yaml:17:13

   ╷
17 │   wakelock: ^0.1.4+2
   │             ^^^^^^^^
   ╵
The constraint `^3.5.0` on xml does not support the latest published version `4.5.1`

pubspec.yaml:20:8

   ╷
20 │   xml: ^3.5.0
   │        ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs