tiki_login 0.0.15 icon indicating copy to clipboard operation
tiki_login: ^0.0.15 copied to clipboard

flutter lib for login

0
likes
100/ 130
pub points
56%
popularity

We analyzed this package 1 hour ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 31 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:tiki_login/tiki_login.dart that imports:
  • package:tiki_login/src/flow/flow_service.dart that imports:
  • package:tiki_login/src/flow/flow_presenter.dart that imports:
  • package:tiki_login/src/flow/flow_layout.dart that imports:
  • package:tiki_login/src/screen_inbox/screen_inbox_service.dart that imports:
  • package:tiki_login/src/screen_inbox/screen_inbox_presenter.dart that imports:
  • package:tiki_login/src/screen_inbox/ui/screen_inbox_layout.dart that imports:
  • package:tiki_login/src/modal_recover/model/modal_recover_model_state.dart that imports:
  • package:tiki_wallet/tiki_wallet.dart that imports:
  • package:tiki_wallet/src/tiki/chain/tiki_chain_service.dart that imports:
  • package:tiki_wallet/src/tiki/chain/tiki_chain_props_repository.dart that imports:
  • package:sqflite_sqlcipher/sqlite_api.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:tiki_login/tiki_login.dart that imports:
  • package:tiki_login/src/flow/flow_service.dart that imports:
  • package:tiki_login/src/flow/flow_presenter.dart that imports:
  • package:tiki_login/src/flow/flow_layout.dart that imports:
  • package:tiki_login/src/screen_inbox/screen_inbox_service.dart that imports:
  • package:tiki_login/src/screen_inbox/screen_inbox_presenter.dart that imports:
  • package:tiki_login/src/screen_inbox/ui/screen_inbox_layout.dart that imports:
  • package:tiki_login/src/modal_recover/model/modal_recover_model_state.dart that imports:
  • package:tiki_wallet/tiki_wallet.dart that imports:
  • package:tiki_wallet/src/tiki/chain/tiki_chain_service.dart that imports:
  • package:tiki_wallet/src/tiki/chain/tiki_chain_props_repository.dart that imports:
  • package:sqflite_sqlcipher/sqlite_api.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:tiki_login/tiki_login.dart that imports:
  • package:tiki_login/src/flow/flow_service.dart that imports:
  • package:tiki_login/src/flow/flow_presenter.dart that imports:
  • package:tiki_login/src/flow/flow_layout.dart that imports:
  • package:tiki_login/src/screen_inbox/screen_inbox_service.dart that imports:
  • package:tiki_login/src/screen_inbox/screen_inbox_presenter.dart that imports:
  • package:tiki_login/src/screen_inbox/ui/screen_inbox_layout.dart that imports:
  • package:tiki_login/src/modal_recover/model/modal_recover_model_state.dart that imports:
  • package:tiki_wallet/tiki_wallet.dart that imports:
  • package:tiki_wallet/src/tiki/chain/tiki_chain_service.dart that imports:
  • package:tiki_wallet/src/tiki/chain/tiki_chain_block.dart that imports:
  • package:tiki_syncchain/tiki_syncchain.dart that imports:
  • package:amplitude_flutter/amplitude.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:tiki_login/tiki_login.dart that imports:
  • package:tiki_login/src/flow/flow_service.dart that imports:
  • package:tiki_login/src/flow/flow_presenter.dart that imports:
  • package:tiki_login/src/flow/flow_layout.dart that imports:
  • package:tiki_login/src/screen_inbox/screen_inbox_service.dart that imports:
  • package:tiki_login/src/screen_inbox/screen_inbox_presenter.dart that imports:
  • package:tiki_login/src/screen_inbox/ui/screen_inbox_layout.dart that imports:
  • package:tiki_login/src/modal_recover/model/modal_recover_model_state.dart that imports:
  • package:tiki_wallet/tiki_wallet.dart that imports:
  • package:tiki_wallet/src/tiki/chain/tiki_chain_service.dart that imports:
  • package:tiki_wallet/src/tiki/chain/tiki_chain_props_repository.dart that imports:
  • package:sqflite_sqlcipher/sqlite_api.dart that declares support for platforms: Android, iOS, macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: ModalRecoverUiView.controller

lib/src/modal_recover/ui/modal_recover_ui_view.dart:13:16

   ╷
13 │ abstract class ModalRecoverUiView extends StatelessWidget {
   │                ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/modal_recover/ui/modal_recover_ui_view.dart

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: ModalRecoverUiView.controller

lib/src/modal_recover/ui/modal_recover_ui_view_account.dart:16:7

   ╷
16 │ class ModalRecoverUiViewAccount extends ModalRecoverUiView {
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/modal_recover/ui/modal_recover_ui_view_account.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
barcode_scan2^4.2.14.2.14.2.1
email_validator^2.0.12.0.12.0.1
firebase_dynamic_links^4.2.64.2.64.2.6
flutterflutter0.0.00.0.0
flutter_markdown^0.6.10+20.6.10+20.6.10+2
flutter_secure_storage^5.0.25.0.25.0.2
httpp^0.0.40.0.40.0.4
logging^1.0.21.0.21.0.2
lottie^1.3.01.3.01.3.0
permission_handler^10.0.010.0.010.0.0
provider^6.0.36.0.36.0.3
tiki_style^0.0.200.0.200.0.20
tiki_wallet^0.0.230.0.240.0.24
url_launcher^6.1.36.1.46.1.4
Transitive dependencies
PackageConstraintCompatibleLatest
amplitude_flutter-3.10.03.10.0
archive-3.3.03.3.0
args-2.3.12.3.1
async-2.9.02.9.0
characters-1.2.01.2.1
charcode-1.3.11.3.1
collection-1.16.01.16.0
convert-3.0.23.0.2
crypto-3.0.23.0.2
firebase_core-1.18.01.18.0
firebase_core_platform_interface-4.4.14.4.1
firebase_core_web-1.6.51.6.5
firebase_dynamic_links_platform_interface-0.2.3+40.2.3+4
fixnum-1.0.11.0.1
flutter_secure_storage_linux-1.1.01.1.0
flutter_secure_storage_macos-1.1.01.1.0
flutter_secure_storage_platform_interface-1.0.01.0.0
flutter_secure_storage_web-1.0.21.0.2
flutter_secure_storage_windows-1.1.21.1.2
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.14.0.1
js-0.6.40.6.4
markdown-5.0.05.0.0
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
nested-1.0.01.0.0
path-1.8.21.8.2
permission_handler_android-10.0.010.0.0
permission_handler_apple-9.0.49.0.4
permission_handler_platform_interface-3.7.03.7.0
permission_handler_windows-0.1.00.1.0
petitparser-5.0.05.0.0
plugin_platform_interface-2.1.22.1.2
pointycastle-3.6.03.6.0
protobuf-2.1.02.1.0
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
sqflite_common-2.2.1+12.2.1+1
sqflite_sqlcipher-2.1.12.1.1
string_scanner-1.1.11.1.1
synchronized-3.0.0+23.0.0+2
term_glyph-1.2.11.2.1
tiki_kv-0.1.10.1.1
tiki_localchain-0.0.60.0.6
tiki_syncchain-0.0.80.0.8
typed_data-1.3.11.3.1
url_launcher_android-6.0.176.0.17
url_launcher_ios-6.0.176.0.17
url_launcher_linux-3.0.13.0.1
url_launcher_macos-3.0.13.0.1
url_launcher_platform_interface-2.1.02.1.0
url_launcher_web-2.0.122.0.12
url_launcher_windows-3.0.13.0.1
uuid-3.0.63.0.6
vector_math-2.1.22.1.2
xml-6.1.06.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.