amplitude_flutter 3.16.2 copy "amplitude_flutter: ^3.16.2" to clipboard
amplitude_flutter: ^3.16.2 copied to clipboard

Amplitude Flutter plugin

pub package

Official Amplitude Flutter SDK #

This is the official Amplitude Flutter SDK developed and maintained by Amplitude Inc.

Installation and Quick Start #

  • Please visit our 💯Developer Center for instructions on installing and using our the SDK.
  • For developing the SDK, please visit our to get started.

Compatibility #

From Amplitude Flutter v3.11.0, we bump up the kotlin version to v1.7.10 to support latest Gradle. For Gradle Version lower than v6.7.1, we recommend to use the Amplitude Flutter v3.10.0. The following matrix lists the minimum support for Amplitude Flutter SDK version.

Amplitude Flutter Gradle Android Gradle Plugin Kotlin Gradle Plugin
3.11.+ 6.7.1 3.6.4 1.7.10

Learn more about the Android Gradle Plugin compatibility, Gradle compatibility, and Kotlin compatibility.

Need Help? #

If you have any problems or issues over our SDK, feel free to create a github issue or submit a request on Amplitude Help.