amplitude_flutter 2.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 91


pub package

Official Amplitude Flutter SDK #

This is the official Amplitude Flutter SDK developed and maintained by Amplitude Inc.

Installation and Quick Start #

Please visit our 💯Developer Center for instructions on installing and using our the SDK.

Need Help? #

If you have any problems or issues over our SDK, feel free to create a github issue or submit a request on Amplitude Help.

2.1.0 #

  • Fix the crash when calling setUserProperties
  • Add API uploadEvents to force uploading unsent events.

2.0.0 #

  • A whole new Flutter SDK which is based on much more stable Amplitude native iOS, Android SDKs

example/lib/main.dart

import 'package:flutter/material.dart';

import 'my_app.dart';

void main() => runApp(const MyApp('a79cefed0b7076cf3998ef7578a18bf0'));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  amplitude_flutter: ^2.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:amplitude_flutter/amplitude.dart';
import 'package:amplitude_flutter/constants.dart';
import 'package:amplitude_flutter/identify.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
91
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
91
Learn more about scoring.

We analyzed this package on Jun 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev
  • Flutter: 1.17.1

Health suggestions

Format lib/amplitude.dart.

Run flutter format to format lib/amplitude.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test