tecfy_core_package 1.0.40
tecfy_core_package: ^1.0.40 copied to clipboard

TecfyCode package is a Flutter client version for Tecfy Core platform built for Tecfy Company projects

1
likes
70/ 130
pub points
60%
popularity

We analyzed this package in the last hour, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 399 out of 1725 API elements (23.1 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Android`.

Because:

  • package:tecfy_core_package/generated_plugin_registrant.dart that imports:
  • package:url_launcher_web/url_launcher_web.dart that declares support for platforms: Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/controllers/home/dashboard.controller.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/main.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ai_barcode^3.0.13.0.13.0.1
ai_barcode_web^3.0.03.0.03.0.0
bot_toast^4.0.14.0.14.0.1
expressions^0.2.30.2.30.2.3
fl_chart^0.40.00.40.50.40.5
flutterflutter0.0.00.0.0
flutter_localizationsflutter0.0.00.0.0
flutter_material_color_picker^1.1.0+21.1.0+21.1.0+2
flutter_slidable^0.6.00.6.01.1.0
flutter_staggered_animations^1.0.01.0.01.0.0
google_maps_flutter^2.0.112.1.12.1.1
google_maps_flutter_web^0.3.20.3.20.3.2
http^0.13.40.13.40.13.4
image_picker_for_web^2.1.32.1.42.1.4
intl^0.17.00.17.00.17.0
localstorage^4.0.0+14.0.0+14.0.0+1
math_expressions^2.2.02.2.02.2.0
package_info^2.0.22.0.22.0.2
path^1.8.01.8.01.8.0
path_provider^2.0.52.0.72.0.7
pdf^3.6.03.6.43.6.4
permission_handler^8.2.28.3.08.3.0
printing^5.6.05.6.55.6.5
pull_to_refresh^2.0.02.0.02.0.0
shared_preferences_web^2.0.02.0.22.0.2
soundpool^2.2.02.2.02.2.0
soundpool_web^2.1.02.1.02.1.0
sqflite^2.0.0+42.0.12.0.1
sqflite_common_ffi^2.1.02.1.02.1.0
tecfy_basic_package^1.0.181.0.181.0.18
universal_html^2.0.82.0.82.0.8
url_launcher^6.0.126.0.176.0.17
url_launcher_web^2.0.42.0.52.0.5
uuid^3.0.53.0.53.0.5
web_socket_channel^2.1.02.1.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
ai_barcode_platform_interface-3.0.03.0.0
archive-3.1.63.1.6
async-2.8.22.8.2
barcode-2.1.02.2.0
cached_network_image-3.2.03.2.0
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
cross_file-0.3.20.3.2
crypto-3.0.13.0.1
csslib-0.17.10.17.1
equatable-2.0.32.0.3
fake_async-1.2.01.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.3.03.3.0
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_web_plugins-0.0.00.0.0
google_maps-5.3.05.3.0
google_maps_flutter_platform_interface-2.1.32.1.3
html-0.15.00.15.0
http_parser-4.0.04.0.0
image-3.1.03.1.0
image_picker-0.8.4+40.8.4+4
image_picker_platform_interface-2.4.12.4.1
js-0.6.30.6.3
js_wrapping-0.7.30.7.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
octo_image-1.0.11.0.1
path_parsing-0.2.11.0.0
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.42.0.4
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
permission_handler_platform_interface-3.7.03.7.0
petitparser-4.4.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
qr-2.1.03.0.0
qr_flutter-4.0.04.0.0
quiver-3.0.1+13.0.1+1
rxdart-0.27.30.27.3
sanitize_html-2.0.02.0.0
shared_preferences-2.0.92.0.9
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_windows-2.0.32.0.3
sky_engine-0.0.990.0.99
soundpool_macos-2.1.32.1.3
soundpool_platform_interface-2.1.02.1.0
source_span-1.8.11.8.1
sqflite_common-2.0.1+12.0.1+1
sqlite3-1.3.11.3.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
universal_io-2.0.42.0.4
universal_platform-1.0.0+11.0.0+1
url_launcher_android-6.0.136.0.13
url_launcher_ios-6.0.136.0.13
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_windows-2.0.22.0.2
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.0` on flutter_slidable does not support the stable version `1.0.0`, that was published 25 days ago.

When flutter_slidable is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_slidable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Unable to access import.

Because:

  • package:tecfy_core_package/generated_plugin_registrant.dart that imports:
  • package:soundpool_web/soundpool_web.dart that imports:
  • dart:web_audio where dart:web_audio is inaccessible.
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.