stream_chat 7.2.1 copy "stream_chat: ^7.2.1" to clipboard
stream_chat: ^7.2.1 copied to clipboard

The official Dart client for Stream Chat, a service for building chat applications.

63
likes
120/ 160
pub points
87%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/GetStream/stream-chat-flutter/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1467 out of 1705 API elements (86.0 %) have documentation comments.

Some symbols that are missing documentation: stream_chat, stream_chat.AcceptInviteResponse.duration, stream_chat.AddMembersResponse.duration, stream_chat.Attachment.authorIcon, stream_chat.Attachment.authorLink.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/core/models/attachment_file.freezed.dart:142:17

    ╷
142 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/core/models/attachment_file.freezed.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/core/models/attachment_file.freezed.dart:301:17

    ╷
301 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/core/models/attachment_file.freezed.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.11.0 2.11.0 2.11.0
collection ^1.17.2 1.19.0 1.19.0
dio ^5.3.2 5.4.3+1 5.4.3+1
equatable ^2.0.5 2.0.5 2.0.5
freezed_annotation ^2.4.1 2.4.1 2.4.1
http_parser ^4.0.2 4.0.2 4.0.2
jose ^0.3.4 0.3.4 0.3.4
json_annotation ^4.8.1 4.9.0 4.9.0
logging ^1.2.0 1.2.0 1.2.0
meta ^1.9.1 1.15.0 1.15.0
mime ^1.0.4 1.0.5 1.0.5
rate_limiter ^1.0.0 1.0.0 1.0.0
rxdart ^0.27.7 0.27.7 0.28.0
synchronized ^3.1.0 3.1.0+1 3.1.0+1
uuid ^4.2.1 4.4.0 4.4.0
web_socket_channel ^2.4.0 2.4.5 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
asn1lib - 1.5.3 1.5.3
boolean_selector - 2.1.1 2.1.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
crypto_keys - 0.3.0+1 0.3.0+1
fixnum - 1.1.0 1.1.0
http - 1.2.1 1.2.1
js - 0.7.1 0.7.1
matcher - 0.12.16+1 0.12.16+1
path - 1.9.0 1.9.0
pointycastle - 3.9.1 3.9.1
quiver - 3.2.1 3.2.1
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.2 0.7.2
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1
x509 - 0.2.4+2 0.2.4+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.27.7` on rxdart does not support the stable version `0.28.0`, that was published 0 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

The constraint `^2.4.0` on web_socket_channel does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions web_socket_channel to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.