snosey_flutter_package 0.8.6
snosey_flutter_package: ^0.8.6 copied to clipboard

Snosey Private Flutter Package.

0
likes
70/ 130
pub points
56%
popularity

We analyzed this package in the last hour, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 173 API elements (0.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:snosey_flutter_package/snosey_flutter_package.dart that imports:
  • package:snosey_flutter_package/api/ApiControllerOld.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that declares support for platforms: Android, iOS, Linux.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/CustomNotification.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/api/BaseModel.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
carousel_slider^4.0.04.0.04.0.0
dio^4.0.04.0.44.0.4
file_picker^4.1.44.2.74.2.7
firebase_messaging^10.0.810.0.911.2.0
flutterflutter0.0.00.0.0
flutter_local_notifications^9.0.09.1.49.1.4
flutter_localizationsflutter0.0.00.0.0
flutter_secure_storage^4.2.14.2.15.0.2
fluttertoast^8.0.88.0.88.0.8
get^4.3.84.5.14.5.1
http^0.13.40.13.40.13.4
http_parser^4.0.04.0.04.0.0
intl^0.17.00.17.00.17.0
json_annotationany4.4.04.4.0
mime^1.0.01.0.11.0.1
photo_view^0.13.00.13.00.13.0
shared_preferences^2.0.82.0.92.0.9
shimmer^2.0.02.0.02.0.0
timeago^3.1.03.1.03.1.0
url_launcher^6.0.26.0.176.0.17
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
dbus-0.5.60.6.6
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase_core-1.10.21.10.2
firebase_core_platform_interface-4.2.04.2.0
firebase_core_web-1.4.01.4.0
firebase_messaging_platform_interface-3.1.03.1.0
firebase_messaging_web-2.2.12.2.1
flutter_local_notifications_linux-0.3.00.3.0
flutter_local_notifications_platform_interface-5.0.05.0.0
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-2.1.22.1.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timezone-0.8.00.8.0
typed_data-1.3.01.3.0
url_launcher_android-6.0.136.0.13
url_launcher_ios-6.0.136.0.13
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.52.0.5
url_launcher_windows-2.0.22.0.2
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^10.0.8` on firebase_messaging does not support the stable version `11.0.0`.

Try running dart pub upgrade --major-versions firebase_messaging to update the constraint.

The constraint `^4.2.1` on flutter_secure_storage does not support the stable version `5.0.0`, that was published 24 days ago.

When flutter_secure_storage is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_secure_storage to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.