simplest 1.0.1+2
simplest: ^1.0.1+2 copied to clipboard

Provider prebuilt services and components to help reduce boilerplate code and build a Flutter app as fast and simplest way.

3
likes
70 / 110
pub points
46 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 136 API elements (15.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:simplest/simplest.dart that imports:
  • package:simplest/src/utils/utils.dart that imports:
  • package:simplest/src/utils/extension/extensions.dart that imports:
  • package:simplest/src/utils/extension/phone_number_ext.dart that imports:
  • package:libphonenumber/libphonenumber.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: Name types using UpperCamelCase.

lib/src/deprecated/translate.dart:3:7

  ╷
3 │ class allTranslations {
  │       ^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/deprecated/translate.dart

INFO: 'getCurrentPosition' is deprecated and shouldn't be used. Call Geolocator.getCurrentPosition() instead.This feature was deprecated after 6.0.0+4..

lib/src/services/location_service.dart:22:37

   ╷
22 │       final currentLocation = await getCurrentPosition();
   │                                     ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/services/location_service.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
app_settings^4.0.44.1.04.1.0
auto_size_text^2.1.02.1.02.1.0
cached_network_image^2.3.32.5.13.0.0
device_info^1.0.01.0.02.0.0
diacritic^0.1.10.1.30.1.3
dio^3.0.103.0.104.0.0
equatable^1.2.51.2.62.0.0
firebase_auth^0.18.30.18.4+11.1.1
firebase_core^0.5.20.5.31.0.4
firebase_database^4.3.04.4.06.1.2
firebase_messaging^7.0.37.0.39.1.2
flutterflutter0.0.00.0.0
flutter_bloc^6.1.16.1.37.0.0
flutter_local_notifications^3.0.1+33.0.35.0.0+1
flutter_spinkit^4.1.2+14.1.2+15.0.0
flutter_svg^0.19.10.19.30.22.0
font_awesome_flutter^8.10.08.12.09.0.0
freezed_annotation^0.12.00.12.00.14.1
geolocator^6.1.66.2.17.0.3
get^3.21.13.26.04.1.4
get_it^5.0.15.0.66.1.1
google_fonts^1.1.11.1.22.0.0
google_maps_flutter^1.0.61.2.02.0.3
image_picker^0.6.7+140.6.7+220.7.4
injectable^1.0.51.1.21.2.2
intl^0.16.10.16.10.17.0
intl_phone_number_input^0.5.2+20.5.2+20.7.0+1
libphonenumber^1.0.21.0.22.0.0
logger^0.9.40.9.41.0.0
material_design_icons_flutter^4.0.57554.0.59554.0.5955
modal_progress_hud^0.1.30.1.30.1.3
pin_code_text_field^1.7.11.8.01.8.0
progress_dialog^1.2.41.2.41.2.4
pull_to_refresh^1.6.21.6.51.6.5
retrofit^1.3.4+11.3.4+11.3.4+1
rxdart^0.24.10.24.10.26.0
shared_preferences^0.5.12+40.5.12+42.0.5
shimmer^1.1.21.1.22.0.0
sliding_up_panel^1.0.21.0.21.0.2
stacked_services^0.5.4+40.5.4+50.8.3
url_launcher^5.7.105.7.106.0.3
webview_flutter^1.0.71.0.72.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.0.0
async-2.5.02.5.0
bloc-6.1.37.0.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
device_info_platform_interface-1.0.12.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
firebase_auth_platform_interface-2.1.44.1.1
firebase_auth_web-0.3.2+31.0.7
firebase_core_platform_interface-2.1.04.0.0
firebase_core_web-0.2.1+11.0.2
flutter_blurhash-0.5.00.6.0
flutter_cache_manager-2.1.23.0.1
flutter_local_notifications_platform_interface-2.0.0+13.0.0
flutter_plugin_android_lifecycle-1.0.112.0.1
flutter_web_plugins-0.0.00.0.0
geolocator_platform_interface-1.0.92.0.2
geolocator_web-1.0.12.0.3
google_maps_flutter_platform_interface-1.2.02.0.4
http-0.12.20.13.1
http_parser-3.1.44.0.0
image-2.1.193.0.2
image_picker_platform_interface-1.1.62.1.0
js-0.6.30.6.3
json_annotation-3.1.14.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
nested-1.0.01.0.0
octo_image-0.3.01.0.0+1
path-1.8.01.8.0
path_drawing-0.4.1+10.5.0
path_parsing-0.1.40.2.0
path_provider-1.6.282.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
pedantic-1.11.01.11.0
petitparser-3.1.04.1.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
provider-4.3.35.0.0
quiver-2.1.53.0.1
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+32.0.0+3
sqflite_common-2.0.0+22.0.0+2
stack_trace-1.10.01.10.0
stream_transform-1.2.02.0.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
timezone-0.5.90.7.0
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.2
url_launcher_web-0.1.5+32.0.0
url_launcher_windows-0.0.1+32.0.0
uuid-2.2.23.0.4
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0
xml-4.5.15.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 30 issues. Showing the first 2:

The constraint `^2.3.3` on cached_network_image does not support the stable version `3.0.0`, that was published 25 days ago.

When cached_network_image is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^1.0.0` on device_info does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions device_info to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.