simpler_login 0.0.1+12 copy "simpler_login: ^0.0.1+12" to clipboard
simpler_login: ^0.0.1+12 copied to clipboard

A new flutter plugin project.

3
likes
100/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://teamdrt.co.in was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

15 out of 27 API elements (55.6 %) have documentation comments.

Some symbols that are missing documentation: platform_interface_simpler_login, platform_interface_simpler_login.SimplerLoginPlatformInterface, platform_interface_simpler_login.SimplerLoginPlatformInterface.SimplerLoginPlatformInterface, platform_interface_simpler_login.SimplerLoginPlatformInterface.forceResendingToken, platform_interface_simpler_login.SimplerLoginPlatformInterface.googleSignIn.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:simpler_login/simpler_login.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:simpler_login/simpler_login.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:simpler_login/simpler_login.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:simpler_login/simpler_login.dart that imports:
  • package:simpler_login/platform_interface_simpler_login.dart that imports:
  • package:firebase_auth/firebase_auth.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

WARNING: This function has a nullable return type of 'FutureOr

lib/platform_interface_simpler_login.dart:49:27

   ╷
49 │   Future<UserCredential?> createUserWithEmailAndPassword({
   │                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/platform_interface_simpler_login.dart

WARNING: This function has a nullable return type of 'FutureOr

lib/platform_interface_simpler_login.dart:102:27

    ╷
102 │   Future<UserCredential?> signInWithEmailAndPassword({
    │                           ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/platform_interface_simpler_login.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
firebase_auth ^3.0.1 3.11.2 4.19.2
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
google_fonts ^2.1.0 2.3.3 6.2.1
google_sign_in ^5.0.5 5.4.4 6.2.1
plugin_platform_interface ^2.0.1 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.0.2 1.3.30
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
cloud_firestore_platform_interface - 5.7.7 6.2.0
cloud_firestore_web - 2.8.10 3.12.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
fake_async - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
firebase_auth_platform_interface - 6.10.1 7.2.3
firebase_auth_web - 4.6.1 5.11.2
firebase_core - 1.24.0 2.30.0
firebase_core_platform_interface - 4.8.0 5.0.0
firebase_core_web - 1.7.3 2.15.0
flutter_test - 0.0.0 0.0.0
google_sign_in_android - 6.1.23 6.1.23
google_sign_in_ios - 5.7.6 5.7.6
google_sign_in_platform_interface - 2.4.5 2.4.5
google_sign_in_web - 0.10.2+1 0.12.4
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.17.0 0.19.0
js - 0.6.7 0.7.1
leak_tracker - 10.0.0 10.0.5
leak_tracker_flutter_testing - 2.0.1 3.0.5
leak_tracker_testing - 2.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 13.0.0 14.2.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^3.0.1` on firebase_auth does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

The constraint `^2.1.0` on google_fonts does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions google_fonts to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.