share_apps 0.3.2 copy "share_apps: ^0.3.2" to clipboard
share_apps: ^0.3.2 copied to clipboard

Put your app in front of everyone through their peers. Peer-to-peer invitations in a very subtle and simple way.

5
likes
100/ 160
pub points
33%
popularity

We analyzed this package 27 hours ago, and awarded it 100 pub points (of a possible 160):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://www.shareapps.net/how-it-works was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

8 out of 216 API elements (3.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: app_registration_screen, app_registration_screen.AppRegistrationScreen, app_registration_screen.AppRegistrationScreen.AppRegistrationScreen, app_registration_screen.isGetCountryList, app_registration_screen.userBean.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:share_apps/share_apps.dart that imports:
  • package:share_apps/src/share_apps.dart that imports:
  • package:share_apps/utils/common_utils.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:share_apps/share_apps.dart that imports:
  • package:share_apps/src/share_apps.dart that imports:
  • package:share_apps/utils/common_utils.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:share_apps/share_apps.dart that imports:
  • package:share_apps/src/share_apps.dart that imports:
  • package:share_apps/utils/common_utils.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:share_apps/share_apps.dart that imports:
  • package:share_apps/src/share_apps.dart that imports:
  • package:share_apps/screens/invitation_form.dart that imports:
  • package:share_apps/screens/app_registration_screen.dart that imports:
  • package:share_apps/screens/home_screen.dart that imports:
  • package:share_apps/screens/email_invitation_loading_screen.dart that imports:
  • package:share_apps/screens/invite_email_screen.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:share_apps/share_apps.dart that imports:
  • package:share_apps/src/share_apps.dart that imports:
  • package:share_apps/utils/common_utils.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:share_apps/share_apps.dart that imports:
  • package:share_apps/src/share_apps.dart that imports:
  • package:share_apps/utils/common_utils.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 56 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'false'.

lib/screens/app_registration_screen.dart:86:56

   ╷
86 │       if (statusCode < 200 || statusCode > 400 || json == null) {
   │                                                        ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/screens/app_registration_screen.dart

WARNING: The operand can't be null, so the condition is always 'true'.

lib/screens/app_registration_screen.dart:109:75

    ╷
109 │       if (map[StringUtils.STATUS].toString().compareTo(StringUtils.SUCCESS) !=
    │ ┌───────────────────────────────────────────────────────────────────────────^
110 │ │         null) {
    │ └────────────^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/screens/app_registration_screen.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
contacts_service ^0.6.3 0.6.3 0.6.3
device_info_plus ^9.1.1 9.1.2 10.1.0
dropdown_search ^5.0.6 5.0.6 5.0.6
fk_user_agent ^2.1.0 2.1.0 2.1.0
flutter flutter 0.0.0 0.0.0
fluttertoast ^8.2.2 8.2.6 8.2.6
http ^0.13.6 0.13.6 1.2.1
loading_indicator ^3.1.1 3.1.1 3.1.1
permission_handler ^11.0.1 11.3.1 11.3.1
shared_preferences ^2.2.2 2.2.3 2.2.3
url_launcher ^6.1.11 6.3.0 6.3.0
webview_flutter ^4.4.1 4.8.0 4.8.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
permission_handler_android - 12.0.7 12.0.7
permission_handler_apple - 9.4.5 9.4.5
permission_handler_html - 0.1.1 0.1.1
permission_handler_platform_interface - 4.2.1 4.2.1
permission_handler_windows - 0.2.1 0.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
quiver - 3.2.1 3.2.1
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.2
typed_data - 1.3.2 1.3.2
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
webview_flutter_android - 3.16.4 3.16.4
webview_flutter_platform_interface - 2.10.0 2.10.0
webview_flutter_wkwebview - 3.13.1 3.13.1
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^9.1.1` on device_info_plus does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint `^0.13.6` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

5
likes
100
pub points
33%
popularity

Publisher

verified publishershareapps.net

Put your app in front of everyone through their peers. Peer-to-peer invitations in a very subtle and simple way.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

contacts_service, device_info_plus, dropdown_search, fk_user_agent, flutter, fluttertoast, http, loading_indicator, permission_handler, shared_preferences, url_launcher, webview_flutter

More

Packages that depend on share_apps