rich_editor 0.0.5
rich_editor: ^0.0.5 copied to clipboard

WYSIWYG editor for Flutter with a rich set of supported formatting options.

27
likes
110/ 130
pub points
77%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 63 out of 142 API elements (44.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:rich_editor/rich_editor.dart that imports:
  • package:rich_editor/src/widgets/editor_tool_bar.dart that imports:
  • package:rich_editor/src/utils/javascript_executor_base.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_colorpicker^0.5.00.5.01.0.2
flutter_inappwebview^5.3.25.3.25.3.2
flutter_widget_from_html_core^0.6.1+10.6.20.8.2
image_picker^0.8.3+10.8.4+40.8.4+4
mime^1.0.01.0.11.0.1
path^1.8.01.8.01.8.0
xml2json^5.3.15.3.15.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
cross_file-0.3.20.3.2
csslib-0.17.10.17.1
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_web_plugins-0.0.00.0.0
html-0.15.00.15.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
image_picker_for_web-2.1.42.1.4
image_picker_platform_interface-2.4.12.4.1
js-0.6.30.6.3
meta-1.7.01.7.0
petitparser-4.4.04.4.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.0` on flutter_colorpicker does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions flutter_colorpicker to update the constraint.

The constraint `^0.6.1+1` on flutter_widget_from_html_core does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions flutter_widget_from_html_core to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.