rapidfire 0.0.1-alpha.3.0
rapidfire: ^0.0.1-alpha.3.0 copied to clipboard

RapidFire Flutter Library is a comprehensive ORM system for mobile application development, used various popular Dart packages in one place. Validation, CRUD and API operations are automatic requires

4
likes
30 / 110
pub points
54 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 30 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 13054 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:flutter/material.dart'.

lib/AccessControl.dart:2:8

  ╷
2 │ import 'package:flutter/material.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/AccessControl.dart

ERROR: Target of URI doesn't exist: 'package:rapidfire/GlobalScopeRF.dart'.

lib/AccessControl.dart:3:8

  ╷
3 │ import 'package:rapidfire/GlobalScopeRF.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/AccessControl.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because rapidfire depends on flutter_localizations any from sdk which depends on intl 0.17.0, intl 0.17.0 is required.
So, because rapidfire depends on intl ^0.16.1, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.