http_server 0.9.8+3

Utility classes for HTTP server #

A set of high-level classes that, together with HttpServer, makes is easier to serve web content.

NOTE: This package only works for server-side or command-line Dart applications. In other words, if the app imports dart:io, it can use this package.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.9.8+3 #

  • Prepare for HttpClientResponse SDK change (implements Stream<Uint8List> rather than Stream<List<int>>).

0.9.8+2 #

  • Prepare for File.openRead() SDK change in signature.

0.9.8+1 #

  • Fix a Dart 2 type issue.

0.9.8 #

  • Updates to support Dart 2 constants.

0.9.7 #

  • Updates to support Dart 2.0 core library changes (wave 2.2). See issue 31847 for details.

0.9.6 #

  • Updated the secure networking code to the SDKs version 1.15 SecurityContext api

0.9.5+1 #

  • Updated the layout of package contents.

0.9.5 #

  • Removed the decoding of HTML entity values (in the form &#xxxxx;) for values when parsing multipart/form-post requests.

0.9.4 #

  • Fixed bugs in the handling of the Range header

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_server: ^0.9.8+3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_server/http_server.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
88
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
88
Learn more about scoring.

We analyzed this package on Sep 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:http_server/http_server.dart with components: io.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and http_server.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
mime >=0.9.0 <0.10.0 0.9.6+3
path >=0.9.0 <2.0.0 1.6.4
Dev dependencies
pedantic ^1.3.0
test ^1.2.0