promize_sdk 0.2.3 copy "promize_sdk: ^0.2.3" to clipboard
promize_sdk: ^0.2.3 copied to clipboard

A data collection SDK provides an easy way to collect your users data and interests

0
likes
140/ 160
pub points
23%
popularity

We analyzed this package 18 hours ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://promize.io/ was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

63 out of 280 API elements (22.5 %) have documentation comments.

Some symbols that are missing documentation: add_event_request, add_event_request.AddEventRequest, add_event_request.AddEventRequest.AddEventRequest, add_event_request.AddEventRequest.email, add_event_request.AddEventRequest.eventData.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:promize_sdk/promize_sdk.dart that imports:
  • package:promize_sdk/manager.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:promize_sdk/promize_sdk.dart that imports:
  • package:promize_sdk/manager.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:promize_sdk/promize_sdk.dart that imports:
  • package:promize_sdk/manager.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:promize_sdk/promize_sdk.dart that imports:
  • package:promize_sdk/manager.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package not compatible with platform Web

Because:

  • package:promize_sdk/promize_sdk.dart that imports:
  • package:promize_sdk/manager.dart that imports:
  • package:promize_sdk/core/Network/network.dart that imports:
  • package:promize_sdk/core/failure_handler.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dartz ^0.10.1 0.10.1 0.10.1
device_info_plus ^9.0.3 9.1.2 10.1.0
dio ^5.3.2 5.5.0+1 5.5.0+1
equatable ^2.0.5 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
get_it ^7.2.0 7.7.0 7.7.0
package_info_plus ^4.1.0 4.2.0 8.0.0
plugin_platform_interface ^2.1.6 2.1.8 2.1.8
pretty_dio_logger ^1.3.1 1.3.1 1.3.1
shared_preferences ^2.0.7 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
device_info_plus_platform_interface - 7.0.0 7.0.0
dio_web_adapter - 1.0.1 1.0.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
http - 1.2.2 1.2.2
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
package_info_plus_platform_interface - 2.0.1 3.0.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
platform - 3.1.5 3.1.5
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.2.1 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 1.0.0 1.0.0
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^9.0.3` on device_info_plus does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint `^4.1.0` on package_info_plus does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions package_info_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
140
pub points
23%
popularity

Publisher

verified publisherpromize.io

A data collection SDK provides an easy way to collect your users data and interests

Homepage

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

dartz, device_info_plus, dio, equatable, flutter, flutter_web_plugins, get_it, package_info_plus, plugin_platform_interface, pretty_dio_logger, shared_preferences

More

Packages that depend on promize_sdk