power_logger 1.2.2 copy "power_logger: ^1.2.2" to clipboard
power_logger: ^1.2.2 copied to clipboard

discontinuedreplaced by: flutter_ume

A well log tool on flutter, support Dio and custom type data.

2
likes
80/ 140
pub points
0%
popularity

We analyzed this package 42 hours ago, and awarded it 80 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

19 out of 39 API elements (48.7 %) have documentation comments.

Some symbols that are missing documentation: power_logger, power_logger.CustomParser, power_logger.DioErrorBuilder.data, power_logger.DioErrorBuilder.date, power_logger.DioResponseBuilder.data.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:power_logger/power_logger.dart that imports:
  • package:power_logger/src/power_logger_view.dart that imports:
  • package:power_logger/src/views/info_view.dart that imports:
  • package:power_logger/src/views/platform_specific/_windows_view.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_windows/device_info_plus_windows.dart that declares support for platforms: Windows.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:power_logger/power_logger.dart that imports:
  • package:power_logger/src/power_logger_view.dart that imports:
  • package:power_logger/src/views/info_view.dart that imports:
  • package:power_logger/src/views/platform_specific/_windows_view.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_windows/device_info_plus_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:power_logger/power_logger.dart that imports:
  • package:power_logger/src/power_logger_view.dart that imports:
  • package:power_logger/src/views/info_view.dart that imports:
  • package:power_logger/src/views/platform_specific/_windows_view.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_windows/device_info_plus_windows.dart that declares support for platforms: Windows.
Package does not support platform `Windows`.

Because:

  • package:power_logger/power_logger.dart that imports:
  • package:power_logger/src/power_logger_view.dart that imports:
  • package:power_logger/src/views/info_view.dart that imports:
  • package:power_logger/src/views/platform_specific/_windows_view.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_linux/device_info_plus_linux.dart that declares support for platforms: Linux.
Package does not support platform `Linux`.

Because:

  • package:power_logger/power_logger.dart that imports:
  • package:power_logger/src/power_logger_view.dart that imports:
  • package:power_logger/src/views/info_view.dart that imports:
  • package:power_logger/src/views/platform_specific/_windows_view.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_windows/device_info_plus_windows.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:power_logger/power_logger.dart that imports:
  • package:power_logger/src/power_logger_view.dart that imports:
  • package:power_logger/src/views/info_view.dart that imports:
  • package:power_logger/src/views/platform_specific/_windows_view.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_windows/device_info_plus_windows.dart that declares support for platforms: Windows.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 25 issues. Showing the first 2:

ERROR: The getter 'accentColor' isn't defined for the type 'ThemeData'.

lib/src/views/info_view.dart:75:48

   ╷
75 │                   tileColor: Theme.of(context).accentColor.withOpacity(0.2),
   │                                                ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/views/info_view.dart

ERROR: The getter 'accentColor' isn't defined for the type 'ThemeData'.

lib/src/views/info_view.dart:85:48

   ╷
85 │                   tileColor: Theme.of(context).accentColor.withOpacity(0.1),
   │                                                ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/views/info_view.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
device_info_plus ^2.0.1 2.2.0 10.1.0
dio ^4.0.0 4.0.6 5.4.3+1
flutter flutter 0.0.0 0.0.0
flutter_highlight ^0.7.0 0.7.0 0.7.0
logger ^1.0.0 1.4.0 2.2.0
package_info_plus ^1.0.3 1.4.2 7.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
device_info_plus_linux - 2.1.1 5.0.0
device_info_plus_macos - 2.2.3 5.0.0
device_info_plus_platform_interface - 2.6.1 7.0.0
device_info_plus_web - 2.1.0 5.0.0
device_info_plus_windows - 2.1.1 6.0.0
ffi - 1.2.1 2.1.2
file - 6.1.4 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
highlight - 0.7.0 0.7.0
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
package_info_plus_linux - 1.0.5 2.0.0
package_info_plus_macos - 1.3.0 2.0.0
package_info_plus_platform_interface - 1.0.2 3.0.0
package_info_plus_web - 1.0.6 2.0.0
package_info_plus_windows - 1.0.5 3.0.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
win32 - 2.6.1 5.4.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.0.1` on device_info_plus does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.