oph_elements 0.0.1+22 icon indicating copy to clipboard operation
oph_elements: ^0.0.1+22 copied to clipboard

Widget elements for OPH

0
likes
20/ 130
pub points
0%
popularity

We analyzed this package 26 hours ago, and awarded it 20 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 111 API elements (7.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:oph_elements/utils/ImageProcessor.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:oph_elements/utils/ImageProcessor.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Package does not support platform `Windows`.

Because:

  • package:oph_elements/utils/ImageProcessor.dart that imports:
  • package:flutter_image_compress/flutter_image_compress.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:oph_elements/utils/ImageProcessor.dart that imports:
  • package:flutter_image_compress/flutter_image_compress.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:oph_elements/utils/ImageProcessor.dart that imports:
  • package:flutter_image_compress/flutter_image_compress.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:oph_elements/utils/ImageProcessor.dart that imports:
  • package:flutter_image_compress/flutter_image_compress.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:oph_elements/utils/imageProcessor.dart'.

lib/utils/camera_service.dart:6:8

  ╷
6 │ import 'package:oph_elements/utils/imageProcessor.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/utils/camera_service.dart

ERROR: Undefined name 'ImageProcessor'.

lib/utils/camera_service.dart:32:17

   ╷
32 │           await ImageProcessor.cropImg(result, flip: false, ratioWH: 1.5);
   │                 ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/utils/camera_service.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
camera^0.6.00.6.4+50.9.8+1
datetime_picker_formfield^2.0.02.0.02.0.0
flutterflutter0.0.00.0.0
flutter_chips_input^1.9.51.10.02.0.0
flutter_image_compress^0.7.00.7.01.1.0
flutter_typeahead^1.9.11.9.34.0.0
geocoder^0.2.10.2.10.2.1
google_maps^4.0.04.0.06.2.0
google_maps_flutter^1.1.11.2.02.1.8
image^3.0.23.1.33.2.0
intl^0.17.00.17.00.17.0
location^3.2.43.2.44.4.0
oph_core^0.0.1+400.0.1+410.0.1+43
path_provider^1.6.21.6.282.0.11
permission_handler^5.0.1+15.1.0+210.0.0
storage_path^0.2.00.2.00.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.3.03.3.0
camera_platform_interface-1.5.02.2.0
characters-1.2.01.2.1
charcode-1.3.11.3.1
clock-1.1.11.1.1
collection-1.16.01.16.0
connectivity-2.0.23.0.6
connectivity_for_web-0.3.1+40.4.0+1
connectivity_macos-0.1.0+70.2.1+2
connectivity_platform_interface-1.0.62.0.1
cross_file-0.1.00.3.3+1
crypto-3.0.23.0.2
ffi-1.2.12.0.1
file-6.1.26.1.2
flutter_keyboard_visibility-4.0.65.3.0
flutter_keyboard_visibility_platform_interface-1.0.12.0.0
flutter_keyboard_visibility_web-1.0.12.0.0
flutter_plugin_android_lifecycle-1.0.112.0.6
flutter_web_plugins-0.0.00.0.0
google_maps_flutter_platform_interface-1.2.02.2.0
google_sign_in-5.3.35.3.3
google_sign_in_android-5.2.85.2.8
google_sign_in_ios-5.3.15.3.1
google_sign_in_platform_interface-2.2.02.2.0
google_sign_in_web-0.10.1+30.10.1+3
group_radio_button-1.2.01.2.0
http-0.12.20.13.4
http_parser-3.1.44.0.1
js-0.6.40.6.4
js_wrapping-0.6.00.7.4
keyboard_actions-3.4.74.0.1
location_platform_interface-1.1.02.3.0
location_web-1.0.13.1.1
matcher-0.12.120.12.12
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
path-1.8.21.8.2
path_provider_linux-0.0.1+22.1.7
path_provider_macos-0.0.4+82.0.6
path_provider_platform_interface-1.0.42.0.4
path_provider_windows-0.0.52.1.0
pedantic-1.11.11.11.1
permission_handler_platform_interface-2.0.23.7.0
petitparser-5.0.05.0.0
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
quiver-3.1.03.1.0
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
stream_transform-1.2.02.0.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
win32-2.6.12.7.0
xdg_directories-0.1.20.2.0+1
xml-5.4.16.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 9 issues. Showing the first 2:

The constraint `^0.6.0` on camera does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions camera to update the constraint.

The constraint `^1.9.5` on flutter_chips_input does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_chips_input to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 3.0.2, Dart 2.17.3.