oph_core 0.0.1+41 icon indicating copy to clipboard operation
oph_core: ^0.0.1+41 copied to clipboard

Package for OPH Core functions

0
likes
60/ 130
pub points
1%
popularity

We analyzed this package 4 hours ago, and awarded it 60 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 396 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:oph_core/oph_core.dart that imports:
  • package:oph_core/utils/browse_service.dart that imports:
  • package:oph_core/utils/form_service.dart that imports:
  • package:oph_core/models/oph.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^2.0.22.0.23.0.6
flutterflutter0.0.00.0.0
google_sign_in^5.0.35.2.35.2.3
group_radio_button^1.1.01.1.01.1.0
http^0.12.0+20.12.20.13.4
intl^0.17.00.17.00.17.0
keyboard_actions^3.4.03.4.63.4.6
path^1.7.01.8.11.8.1
path_provider^1.6.281.6.282.0.8
xml^5.1.15.3.15.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
connectivity_for_web-0.3.1+40.4.0+1
connectivity_macos-0.1.0+70.2.1+2
connectivity_platform_interface-1.0.62.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
google_sign_in_platform_interface-2.1.12.1.1
google_sign_in_web-0.10.0+40.10.0+4
http_parser-3.1.44.0.0
js-0.6.30.6.4
matcher-0.12.110.12.11
meta-1.7.01.7.0
path_provider_linux-0.0.1+22.1.5
path_provider_macos-0.0.4+82.0.5
path_provider_platform_interface-1.0.42.0.3
path_provider_windows-0.0.52.0.5
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
quiver-3.0.1+13.0.1+1
sky_engine-0.0.990.0.99
source_span-1.8.21.8.2
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1
win32-2.3.52.3.5
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.0.2` on connectivity does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions connectivity to update the constraint.

The constraint `^0.12.0+2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.8.1, Dart 2.15.1.