openapi_code_builder 1.3.2 copy "openapi_code_builder: ^1.3.2" to clipboard
openapi_code_builder: ^1.3.2 copied to clipboard

Generate Dtos, client and server scaffolds for openapi specs.

14
likes
130/ 160
pub points
46%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 28 API elements (3.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: openapi_code_builder, openapi_code_builder.OpenApiCodeBuilderUtils, openapi_code_builder.OpenApiCodeBuilderUtils.OpenApiCodeBuilderUtils, openapi_code_builder.OpenApiCodeBuilderUtils.formatLibrary, openapi_code_builder.OpenApiCodeBuilderUtils.loadApiFromYaml.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:openapi_code_builder/openapi_code_builder.dart that imports:
  • package:openapi_code_builder/src/openapi_code_builder.dart that imports:
  • package:openapi_base/openapi_base.dart that imports:
  • package:openapi_base/src/server/openapi_shelf_noop_server.dart that imports:
  • package:openapi_base/src/server/openapi_server_base.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
build >=2.0.2 <3.0.0 2.4.1 2.4.1
built_collection >=5.1.0 <6.0.0 5.1.1 5.1.1
code_builder >=4.0.0 <5.0.0 4.10.0 4.10.0
collection >=1.15.0 <2.0.0 1.19.0 1.19.0
dart_style >=2.0.1 <3.0.0 2.3.6 2.3.6
json_annotation >=4.0.1 <6.0.0 4.9.0 4.9.0
logging >=1.0.1 <2.0.0 1.2.0 1.2.0
logging_appenders ^1.1.0 1.3.1 1.3.1
meta >=1.5.0 <2.0.0 1.15.0 1.15.0
open_api_forked ^3.0.0+6 3.0.0+6 3.0.0+6
openapi_base >=1.1.0 <2.0.0 1.3.2 1.3.2
path >=1.8.0 <2.0.0 1.9.0 1.9.0
quiver >=3.0.1 <4.0.0 3.2.1 3.2.1
recase ^4.1.0 4.1.0 4.1.0
source_gen >=1.0.2 <2.0.0 1.5.0 1.5.0
yaml >=3.1.0 <4.0.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 72.0.0
_macros - 0.1.0 0.1.0
analyzer - 6.5.0 6.7.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
built_value - 8.9.2 8.9.2
chunked_stream - 1.4.2 1.4.2
clock - 1.1.1 1.1.1
codable_forked - 1.0.0+3 1.0.0+3
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dio - 5.5.0+1 5.5.0+1
dio_web_adapter - 1.0.1 1.0.1
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
glob - 2.1.2 2.1.2
http - 1.2.1 1.2.1
http_parser - 4.1.0 4.1.0
intl - 0.19.0 0.19.0
macros - 0.1.0-main.0 0.1.2-main.4
matcher - 0.12.16+1 0.12.16+1
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
shelf - 1.4.2 1.4.2
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.3 0.7.3
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
uuid - 4.4.2 4.4.2
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 5 errors:

  • UNDEFINED_METHOD - lib/src/openapi_code_builder.dart:177:19 - The method 'declareFinal' isn't defined for the type 'OpenApiLibraryGenerator'.
  • UNDEFINED_SETTER - lib/src/openapi_code_builder.dart:233:15 - The setter 'sealed' isn't defined for the type 'ClassBuilder'.
  • UNDEFINED_METHOD - lib/src/openapi_code_builder.dart:563:13 - The method 'declareFinal' isn't defined for the type 'OpenApiLibraryGenerator'.

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.