openapi_base 0.1.2

  • Readme
  • Changelog
  • Example
  • Installing
  • new60

openapi_base #

Base (runtime) package for OpenAPI code generator. See https://github.com/hpoul/openapi_dart/tree/master/packages/openapi_code_builder for details and examples.

0.1.2 #

  • Support for optional query parameters
  • Match the whole path on the server (not prefix matching)
  • Improve body types, etc.

0.1.1 #

  • More documentation, various extension methods, etc.

0.1.0 #

Initial release

example/README.md

For example usage see the examples in openapi_code_builder:

https://github.com/hpoul/openapi_dart/tree/master/packages/openapi_code_builder/example

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  openapi_base: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:openapi_base/openapi_base.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
21
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because of the import of dart:io via the import chain package:openapi_base/openapi_base.dartpackage:openapi_base/src/server/openapi_shelf_server.dartpackage:shelf_cookie/shelf_cookie.dartpackage:shelf_cookie/src/shelf_cookie.dartpackage:shelf_cookie/src/cookie_parser.dartdart:io

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:openapi_base/openapi_base.dartpackage:openapi_base/src/server/openapi_shelf_server.dartpackage:shelf_cookie/shelf_cookie.dartpackage:shelf_cookie/src/shelf_cookie.dartpackage:shelf_cookie/src/cookie_parser.dartdart:io

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.8.0 <3.0.0
http ^0.12.1 0.12.1
logging ^0.11.4 0.11.4
logging_appenders ^0.4.2+3 0.4.2+3
meta ^1.1.8 1.1.8
open_api ^2.0.1 2.0.1
shelf ^0.7.7 0.7.7
shelf_cookie ^1.1.1 1.1.1
uri ^0.11.3+1 0.11.3+1
Transitive dependencies
async 2.4.1
charcode 1.1.3
clock 1.0.1
codable 1.0.0
collection 1.14.13
dio 3.0.9
http_parser 3.1.4
intl 0.16.1
io 0.3.4
matcher 0.12.8
path 1.7.0
quiver 2.1.3
rxdart 0.24.1
source_span 1.7.0
stack_trace 1.9.5
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
utf 0.9.0+5
Dev dependencies
pedantic ^1.9.0 1.9.0 1.9.1