nravepay 1.2.3 copy "nravepay: ^1.2.3" to clipboard
nravepay: ^1.2.3 copied to clipboard

Nravepay is a package that makes accepting card payments in a flutter project easier using Flutterwave.

7
likes
120/ 140
pub points
32%
popularity

We analyzed this package 30 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

103 out of 444 API elements (23.2 %) have documentation comments.

Some symbols that are missing documentation: nravepay, nravepay.AddCardPage, nravepay.AddCardPage.AddCardPage, nravepay.Authorization, nravepay.Authorization.Authorization.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:nravepay/nravepay.dart that imports:
  • package:nravepay/src/pages/pages.dart that imports:
  • package:nravepay/src/pages/webview.page.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:nravepay/nravepay.dart that imports:
  • package:nravepay/src/pages/pages.dart that imports:
  • package:nravepay/src/pages/webview.page.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:nravepay/nravepay.dart that imports:
  • package:nravepay/src/pages/pages.dart that imports:
  • package:nravepay/src/pages/webview.page.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:nravepay/nravepay.dart that imports:
  • package:nravepay/src/pages/pages.dart that imports:
  • package:nravepay/src/pages/webview.page.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:nravepay/nravepay.dart that imports:
  • package:nravepay/src/pages/pages.dart that imports:
  • package:nravepay/src/pages/webview.page.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:nravepay/nravepay.dart that imports:
  • package:nravepay/src/pages/pages.dart that imports:
  • package:nravepay/src/pages/webview.page.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_surface_android.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: 'WillPopScope' is deprecated and shouldn't be used. Use PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/src/base/state.base.dart:9:12

  ╷
9 │     return WillPopScope(
  │            ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/base/state.base.dart

INFO: 'WillPopScope.new' is deprecated and shouldn't be used. Use PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/src/base/state.base.dart:9:12

  ╷
9 │     return WillPopScope(
  │            ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/base/state.base.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.8.2 2.11.0 2.11.0
bloc ^8.0.3 8.1.4 8.1.4
cupertino_icons ^1.0.4 1.0.8 1.0.8
dio ^4.0.4 4.0.6 5.4.3+1
equatable ^2.0.3 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.0.1 8.1.5 8.1.5
get_it ^7.2.0 7.7.0 7.7.0
intl ^0.17.0 0.17.0 0.19.0
tripledes_nullsafety ^1.0.3 1.0.3 1.0.3
websafe_svg ^2.1.1 2.1.3+1 3.0.1+1
webview_flutter ^3.0.1 3.0.4 4.7.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
flutter_svg - 1.1.6 2.0.10+1
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_drawing - 1.0.1 1.0.1
path_parsing - 1.0.1 1.0.1
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
webview_flutter_android - 2.10.4 3.16.0
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.13.0
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^4.0.4` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

7
likes
120
pub points
32%
popularity

Publisher

verified publishernelsoneze.com

Nravepay is a package that makes accepting card payments in a flutter project easier using Flutterwave.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

async, bloc, cupertino_icons, dio, equatable, flutter, flutter_bloc, get_it, intl, tripledes_nullsafety, websafe_svg, webview_flutter

More

Packages that depend on nravepay