ngtest 4.1.1 copy "ngtest: ^4.1.1" to clipboard
ngtest: ^4.1.1 copied to clipboard

Platformweb

Testing runner and library for AngularDart. This package is necessary to write component tests for AngularDart components.

3
likes
130/ 160
pub points
58%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting ngtest... Discovering libraries... Linking elements... Precaching local docs for 157285 elements... Initialized dartdoc with 302 libraries Generating docs for library angular_test.dart from package:ngtest/angular_test.dart... Generating docs for library compatibility.dart from package:ngtest/compatibility.dart... Generating docs for library ngtest.dart from package:ngtest/ngtest.dart... Documented 3 public libraries in 36.1 seconds ERR: warning: ambiguous reexport of fake_time_stabilizer.FakeTimeNgZoneStabilizer, canonicalization candidates: (angular_test, angular_test) -> angular_test (confidence 0.000) from fake_time_stabilizer.FakeTimeNgZoneStabilizer: (file:///tmp/pana_SNXJHA/lib/src/frontend/ng_zone/fake_time_stabilizer.dart:20:7) angular_test: 0.01000 - (_Reason.longName (+0.01000)) angular_test: 0.01000 - (_Reason.longName (+0.01000)) Use {@canonicalFor fake_time_stabilizer.FakeTimeNgZoneStabilizer} in the desired library's documentation to resolve the ambiguity and/or override dartdoc's decision, or structure your package so the reexport is less ambiguous. The symbol will still be referenced in all candidates -- this only controls the location where it will be written and which library will be displayed in navigation for the relevant pages. The flag [59 more lines]

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:ngtest/ngtest.dart that imports:
  • package:ngtest/src/frontend.dart that imports:
  • package:ngtest/src/frontend/stabilizer.dart that imports:
  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform iOS

Because:

  • package:ngtest/ngtest.dart that imports:
  • package:ngtest/src/frontend.dart that imports:
  • package:ngtest/src/frontend/stabilizer.dart that imports:
  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Windows

Because:

  • package:ngtest/ngtest.dart that imports:
  • package:ngtest/src/frontend.dart that imports:
  • package:ngtest/src/frontend/stabilizer.dart that imports:
  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Linux

Because:

  • package:ngtest/ngtest.dart that imports:
  • package:ngtest/src/frontend.dart that imports:
  • package:ngtest/src/frontend/stabilizer.dart that imports:
  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform macOS

Because:

  • package:ngtest/ngtest.dart that imports:
  • package:ngtest/src/frontend.dart that imports:
  • package:ngtest/src/frontend/stabilizer.dart that imports:
  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.14.0 <3.0.0' don't guarantee it.

lib/src/frontend/ng_zone/base_stabilizer.dart:70:5

   ╷
70 │     unawaited(onErrorSub.cancel());
   │     ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/frontend/ng_zone/base_stabilizer.dart

INFO: 'SlowComponentLoader' is deprecated and shouldn't be used. Use ComponentLoader with an imported ComponentFactory instead.

lib/compatibility.dart:57:7

   ╷
57 │       SlowComponentLoader: const SlowComponentLoader(
   │       ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/compatibility.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.19.0 1.19.0
meta ^1.3.0 1.15.0 1.15.0
ngdart ^7.1.1 7.1.1 7.1.1
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 47.0.0 72.0.0
analyzer - 4.7.0 6.7.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
build_resolvers - 2.0.10 2.4.2
build_test - 2.2.0 2.2.2
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
charcode - 1.3.1 1.3.1
checked_yaml - 2.0.3 2.0.3
clock - 1.1.1 1.1.1
code_builder - 4.10.0 4.10.0
convert - 3.1.1 3.1.1
coverage - 1.6.4 1.8.0
crypto - 3.0.3 3.0.3
csslib - 0.17.3 1.0.0
dart_style - 2.2.4 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
frontend_server_client - 3.2.0 4.0.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
html - 0.15.4 0.15.4
http_multi_server - 3.2.1 3.2.1
http_parser - 4.1.0 4.1.0
intl - 0.17.0 0.19.0
io - 1.0.4 1.0.4
js - 0.6.7 0.7.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
mime - 1.0.5 1.0.5
ngast - 2.1.4 2.1.4
ngcompiler - 2.1.3 2.1.3
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.3.0 1.3.0
quiver - 3.2.1 3.2.1
shelf - 1.4.2 1.4.2
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
source_gen - 1.2.6 1.5.0
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test - 1.24.3 1.25.7
test_api - 0.6.0 0.7.2
test_core - 0.5.3 0.6.4
typed_data - 1.3.2 1.3.2
vm_service - 11.10.0 14.2.4
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
webkit_inspection_protocol - 1.2.1 1.2.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

3
likes
130
pub points
58%
popularity

Publisher

verified publisherangulardart.xyz

Testing runner and library for AngularDart. This package is necessary to write component tests for AngularDart components.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, meta, ngdart

More

Packages that depend on ngtest