ngcompiler 2.1.3 copy "ngcompiler: ^2.1.3" to clipboard
ngcompiler: ^2.1.3 copied to clipboard

The AngularDart compiler. It compiles your component files written in Dart into templates so that you don't have to worry about all the complicated hassle.

2
likes
130/ 160
pub points
73%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

746 out of 2669 API elements (28.0 %) have documentation comments.

Some symbols that are missing documentation: abstract_emitter, abstract_emitter.AbstractEmitterVisitor, abstract_emitter.AbstractEmitterVisitor.AbstractEmitterVisitor, abstract_emitter.AbstractEmitterVisitor.emitNullSafeSyntax, abstract_emitter.AbstractEmitterVisitor.visitAllExpressions.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:ngcompiler/v1/angular_compiler.dart that imports:
  • package:ngcompiler/v1/src/angular_compiler/outliner.dart that imports:
  • package:ngcompiler/v1/src/angular_compiler/analyzer.dart that imports:
  • package:ngcompiler/v1/src/angular_compiler/analyzer/view/typed_reader.dart that imports:
  • package:ngcompiler/v1/src/angular_compiler/analyzer/types.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:ngcompiler/v1/angular_compiler.dart that imports:
  • package:ngcompiler/v1/src/angular_compiler/outliner.dart that imports:
  • package:ngcompiler/v1/src/angular_compiler/analyzer.dart that imports:
  • package:ngcompiler/v1/src/angular_compiler/analyzer/view/typed_reader.dart that imports:
  • package:ngcompiler/v1/src/angular_compiler/analyzer/types.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:ngcompiler/v1/angular_compiler.dart that imports:
  • package:ngcompiler/v1/src/angular_compiler/outliner.dart that imports:
  • package:ngcompiler/v1/src/angular_compiler/outliner/collect_type_parameters.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 165 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/v1/src/compiler/i18n/message.dart:37:17

   ╷
37 │   bool operator ==(dynamic other) =>
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/v1/src/compiler/i18n/message.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/v1/src/compiler/i18n/metadata.dart:122:17

    ╷
122 │   bool operator ==(dynamic other) =>
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/v1/src/compiler/i18n/metadata.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^4.2.0 4.7.0 6.7.0
args ^2.0.0 2.5.0 2.5.0
build ^2.0.0 2.4.1 2.4.1
build_test ^2.0.0 2.2.0 2.2.2
code_builder ^4.0.0 4.10.0 4.10.0
collection ^1.15.0 1.19.0 1.19.0
csslib ^0.17.0 0.17.3 1.0.0
dart_style ^2.0.0 2.2.4 2.3.6
logging ^1.0.0 1.2.0 1.2.0
meta ^1.1.4 1.15.0 1.15.0
ngast ^2.1.4 2.1.4 2.1.4
ngdart ^7.1.1 7.1.1 7.1.1
package_config ^2.0.0 2.1.0 2.1.0
path ^1.6.1 1.9.0 1.9.0
source_gen ^1.0.0 1.2.6 1.5.0
source_span ^1.4.0 1.10.0 1.10.0
stack_trace ^1.9.1 1.11.1 1.11.1
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 47.0.0 72.0.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build_config - 1.1.1 1.1.1
build_resolvers - 2.0.10 2.4.2
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
charcode - 1.3.1 1.3.1
checked_yaml - 2.0.3 2.0.3
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
coverage - 1.6.4 1.8.0
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
frontend_server_client - 3.2.0 4.0.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
html - 0.15.4 0.15.4
http_multi_server - 3.2.1 3.2.1
http_parser - 4.1.0 4.1.0
intl - 0.17.0 0.19.0
io - 1.0.4 1.0.4
js - 0.6.7 0.7.1
json_annotation - 4.9.0 4.9.0
matcher - 0.12.16+1 0.12.16+1
mime - 1.0.5 1.0.5
node_preamble - 2.0.2 2.0.2
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.3.0 1.3.0
quiver - 3.2.1 3.2.1
shelf - 1.4.2 1.4.2
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test - 1.24.3 1.25.7
test_api - 0.6.0 0.7.2
test_core - 0.5.3 0.6.4
typed_data - 1.3.2 1.3.2
vm_service - 11.10.0 14.2.4
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
webkit_inspection_protocol - 1.2.1 1.2.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.2.0` on analyzer does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.17.0` on csslib does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions csslib to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

2
likes
130
pub points
73%
popularity

Publisher

verified publisherangulardart.xyz

The AngularDart compiler. It compiles your component files written in Dart into templates so that you don't have to worry about all the complicated hassle.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, args, build, build_test, code_builder, collection, csslib, dart_style, logging, meta, ngast, ngdart, package_config, path, source_gen, source_span, stack_trace

More

Packages that depend on ngcompiler