native_updater 0.1.1 copy "native_updater: ^0.1.1" to clipboard
native_updater: ^0.1.1 copied to clipboard

PlatformAndroid

Flutter package for prompting users to update with a native dialog whether using the app store version or any version at the user's discretion.

146
likes
120/ 140
pub points
81%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 4 API elements (25.0 %) have documentation comments.

Some symbols that are missing documentation: native_updater, native_updater.NativeUpdater, native_updater.NativeUpdater.NativeUpdater.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:native_updater/native_updater.dart that imports:
  • package:native_updater/src/native_updater.dart that imports:
  • package:in_app_update/in_app_update.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:native_updater/native_updater.dart that imports:
  • package:native_updater/src/native_updater.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:native_updater/native_updater.dart that imports:
  • package:native_updater/src/native_updater.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:native_updater/native_updater.dart that imports:
  • package:native_updater/src/native_updater.dart that imports:
  • package:in_app_update/in_app_update.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:native_updater/native_updater.dart that imports:
  • package:native_updater/src/native_updater.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: The import of 'package:flutter/material.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/cupertino.dart'.

lib/src/update_cupertino_alert.dart:4:8

  ╷
4 │ import 'package:flutter/material.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/update_cupertino_alert.dart

INFO: 'launch' is deprecated and shouldn't be used. Use launchUrl instead.

lib/src/update_cupertino_alert.dart:43:24

   ╷
43 │       onPressed: () => launch(appStoreUrl),
   │                        ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/update_cupertino_alert.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
in_app_update ^2.0.0 2.0.0 4.2.2
package_info ^2.0.2 2.0.2 2.0.2
url_launcher ^6.0.10 6.2.6 6.2.6
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
url_launcher_android - 6.3.1 6.3.1
url_launcher_ios - 6.2.5 6.2.5
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.0 2.3.0
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on in_app_update does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions in_app_update to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

146
likes
120
pub points
81%
popularity

Publisher

verified publisherofload.com

Flutter package for prompting users to update with a native dialog whether using the app store version or any version at the user's discretion.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, in_app_update, package_info, url_launcher

More

Packages that depend on native_updater