multipack 0.1.3

Dart native
Flutter Android iOS

A tool for monorepo management. Link local packages and execute commands in topological order.

2
likes
70 / 110
pub points
1 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 81 API elements (7.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:multipack/commands.dart that imports:
  • package:multipack/commands/pubspec.dart that imports:
  • package:multipack/package.dart that imports:
  • package:pubspec/pubspec.dart that imports:
  • package:pubspec/src/pubspec.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.0.21.0.51.0.5
args^1.6.01.6.01.6.0
directed_graph^0.1.40.1.90.2.3
meta^1.0.01.2.31.2.3
path^1.6.41.7.01.7.0
pub_semver^1.4.41.4.41.4.4
pubspec^0.1.20.1.50.1.5
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
graphs-0.2.00.2.0
lazy_evaluation-0.0.6+30.0.6+3
matcher-0.12.90.12.9
quiver-2.1.32.1.3
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
uri-0.11.3+10.11.3+1
utf-0.9.0+50.9.0+5
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.4` on directed_graph does not support the latest published version `0.2.3`

pubspec.yaml:10:19

   ╷
10 │   directed_graph: ^0.1.4
   │                   ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

2
likes
70
pub points
1%
popularity

Publisher

gql-dart.dev

A tool for monorepo management. Link local packages and execute commands in topological order.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ansicolor, args, directed_graph, meta, path, pub_semver, pubspec

More

Packages that depend on multipack