msk_utils 2.0.1 copy "msk_utils: ^2.0.1" to clipboard
msk_utils: ^2.0.1 copied to clipboard

Flutter utility package, with utilities for navigation, databases, and extensions for strings, maps, lists and more

0
likes
130/ 160
pub points
34%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

24 out of 118 API elements (20.3 %) have documentation comments.

Some symbols that are missing documentation: base_cadastro_const, base_cadastro_const.BaseCadastroConst, base_cadastro_const.BaseCadastroConst.BaseCadastroConst, base_cadastro_const.BaseCadastroConst.REGISTRO_ALTERADO, base_cadastro_const.BaseCadastroConst.REGISTRO_ALTERAR.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:msk_utils/msk_utils.dart that imports:
  • package:msk_utils/domain/utils/utils_hive.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:msk_utils/msk_utils.dart that imports:
  • package:msk_utils/domain/utils/utils_version.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:msk_utils/msk_utils.dart that imports:
  • package:msk_utils/domain/utils/utils_version.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:msk_utils/msk_utils.dart that imports:
  • package:msk_utils/domain/utils/utils_version.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:msk_utils/msk_utils.dart that imports:
  • package:msk_utils/domain/utils/utils_version.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

INFO: Statements in an if should be enclosed in a block.

lib/domain/extensions/list.dart:92:7

   ╷
92 │       return null;
   │       ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/domain/extensions/list.dart

INFO: Statements in an if should be enclosed in a block.

lib/domain/extensions/list.dart:94:7

   ╷
94 │       return this!.first;
   │       ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/domain/extensions/list.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
device_info_plus ^9.0.2 9.1.2 10.1.0
dio ^5.2.0+1 5.5.0+1 5.5.0+1
flutter flutter 0.0.0 0.0.0
flutter_mobx ^2.0.6+5 2.2.1+1 2.2.1+1
hive ^2.2.3 2.2.3 2.2.3
intl ^0.18.1 0.18.1 0.19.0
mobx ^2.2.0 2.3.3+2 2.3.3+2
package_info_plus ^4.0.2 4.2.0 8.0.0
path_provider ^2.0.15 2.1.3 2.1.3
sentry ^7.7.0 7.20.2 8.3.0
sprintf ^7.0.0 7.0.0 7.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
device_info_plus_platform_interface - 7.0.0 7.0.0
dio_web_adapter - 1.0.1 1.0.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
package_info_plus_platform_interface - 2.0.1 3.0.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.7 2.2.7
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.2 4.4.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^9.0.2` on device_info_plus does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint `^0.18.1` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
130
pub points
34%
popularity

Publisher

unverified uploader

Flutter utility package, with utilities for navigation, databases, and extensions for strings, maps, lists and more

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

device_info_plus, dio, flutter, flutter_mobx, hive, intl, mobx, package_info_plus, path_provider, sentry, sprintf

More

Packages that depend on msk_utils