moongate_flutter_sdk 0.0.2 copy "moongate_flutter_sdk: ^0.0.2" to clipboard
moongate_flutter_sdk: ^0.0.2 copied to clipboard

MoonGate Web3 Flutter Authentication SDK

0
likes
110/ 160
pub points
0%
popularity

We analyzed this package 8 hours ago, and awarded it 110 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: GPL-3.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 51 API elements (2.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: auth_webview, auth_webview.AuthWebView, auth_webview.AuthWebView.AuthWebView, auth_webview.AuthWebView.onAuthenticated, auth_webview.AuthWebView.url.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:moongate_flutter_sdk/auth_webview.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:moongate_flutter_sdk/auth_webview.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:moongate_flutter_sdk/auth_webview.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:moongate_flutter_sdk/auth_webview.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

WARNING: The value of the field '_channel' isn't used.

lib/moongate_auth.dart:10:30

   ╷
10 │   static const MethodChannel _channel = const MethodChannel('moongate_auth');
   │                              ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/moongate_auth.dart

WARNING: The value of the field '_authBaseUrl' isn't used.

lib/moongate_auth.dart:13:16

   ╷
13 │   final String _authBaseUrl = 'https://auth.moongate.one/provider';
   │                ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/moongate_auth.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
convert ^3.1.1 3.1.1 3.1.1
crypto ^3.0.1 3.0.3 3.0.3
flutter flutter 0.0.0 0.0.0
flutter_inappwebview ^5.3.2 5.8.0 6.0.0
flutter_secure_storage ^8.0.0 8.1.0 9.2.2
flutter_webview_plugin ^0.4.0 0.4.0 0.4.0
hex ^0.2.0 0.2.0 0.2.0
http ^0.13.3 0.13.6 1.2.1
jwt_decode ^0.3.1 0.3.1 0.3.1
ntcdcrypto ^0.2.0 0.2.0 0.2.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
sha3 ^0.2.0 0.2.0 0.2.0
siwe_flutter ^0.0.12 0.0.13 0.0.13
sss256 ^1.0.0 1.0.0 1.0.0
uni_links ^0.5.0 0.5.1 0.5.1
url_launcher ^6.0.9 6.3.0 6.3.0
walletconnect_dart ^0.0.11 0.0.11 0.0.11
walletconnect_qrcode_modal_dart ^0.4.0 0.4.3 0.4.3
web3dart ^2.6.1 2.6.1 2.7.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
cached_network_image - 3.3.1 3.3.1
cached_network_image_platform_interface - 4.0.0 4.0.0
cached_network_image_web - 1.2.0 1.2.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
cryptography - 2.7.0 2.7.0
eip1559 - 0.6.1 0.6.2
eip55 - 1.0.2 1.0.2
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_cache_manager - 3.3.1 3.3.2
flutter_secure_storage_linux - 1.2.1 1.2.1
flutter_secure_storage_macos - 3.1.2 3.1.2
flutter_secure_storage_platform_interface - 1.1.2 1.1.2
flutter_secure_storage_web - 1.2.1 1.2.1
flutter_secure_storage_windows - 2.1.1 3.1.2
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
js - 0.6.7 0.7.1
json_annotation - 4.9.0 4.9.0
json_rpc_2 - 3.0.2 3.0.2
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
octo_image - 2.0.0 2.0.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.6 2.2.6
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
pointycastle - 3.9.1 3.9.1
qr - 3.0.1 3.0.1
qr_flutter - 4.1.0 4.1.0
rxdart - 0.27.7 0.28.0
sec - 1.1.0 1.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sqflite - 2.3.3+1 2.3.3+1
sqflite_common - 2.5.4 2.5.4
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uni_links_platform_interface - 1.0.0 1.0.0
uni_links_web - 0.1.0 0.1.0
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4
wallet - 0.0.13 0.0.13
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^5.3.2` on flutter_inappwebview does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions flutter_inappwebview to update the constraint.

The constraint `^8.0.0` on flutter_secure_storage does not support the stable version `9.0.0`.

Try running dart pub upgrade --major-versions flutter_secure_storage to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.