linkfive_purchases 4.0.1 copy "linkfive_purchases: ^4.0.1" to clipboard
linkfive_purchases: ^4.0.1 copied to clipboard

Manage your in-app subscriptions with the LinkFive plugin - The Easiest Implementation of Subscriptions.

16
likes
110/ 140
pub points
71%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

415 out of 617 API elements (67.3 %) have documentation comments.

Some symbols that are missing documentation: app_store_product_details_wrapper, app_store_product_details_wrapper.AppStoreProductDetailsWrapper, app_store_product_details_wrapper.AppStoreProductDetailsWrapper.AppStoreProductDetailsWrapper, app_store_product_details_wrapper.AppStoreProductDetailsWrapper.fromProductDetails, currency_symbol.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:linkfive_purchases/linkfive_purchases.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:linkfive_purchases/linkfive_purchases.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:linkfive_purchases/linkfive_purchases.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:linkfive_purchases/linkfive_purchases.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:linkfive_purchases/linkfive_purchases.dart that imports:
  • package:linkfive_purchases/models/pricing_phase.dart that imports:
  • package:linkfive_purchases/models/period.dart that imports:
  • package:in_app_purchase_storekit/store_kit_wrappers.dart that declares support for platforms: iOS, macOS.
Package does not support platform `iOS`.

Because:

  • package:linkfive_purchases/linkfive_purchases.dart that imports:
  • package:linkfive_purchases/models/pricing_phase.dart that imports:
  • package:in_app_purchase_android/billing_client_wrappers.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 26 issues. Showing the first 2:

lib/client/linkfive_billing_client.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/client/linkfive_billing_client_test.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
device_info_plus ^9.1.1 9.1.2 10.1.0
flutter flutter 0.0.0 0.0.0
http ^1.1.0 1.2.0 1.2.1
in_app_purchase ^3.1.13 3.2.0 3.2.0
in_app_purchase_android ^0.3.0+13 0.3.5+1 0.3.5+1
in_app_purchase_platform_interface ^1.3.7 1.4.0 1.4.0
in_app_purchase_storekit ^0.3.6+7 0.3.16 0.3.16
in_app_purchases_interface ^1.0.0 1.0.0 1.0.0
json_annotation ^4.8.1 4.9.0 4.9.0
package_info_plus ^5.0.1 5.0.1 8.0.0
shared_preferences ^2.2.2 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
package_info_plus_platform_interface - 2.0.1 3.0.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.2.2 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.4.2 0.5.1
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^9.1.1` on device_info_plus does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint `^5.0.1` on package_info_plus does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions package_info_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.