learning_input_image 0.0.6+1 copy "learning_input_image: ^0.0.6+1" to clipboard
learning_input_image: ^0.0.6+1 copied to clipboard

PlatformAndroidiOS
outdated

Input image package to be used by other learning plugins.

3
likes
110/ 160
pub points
66%
popularity

We analyzed this package 21 hours ago, and awarded it 110 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

32 out of 75 API elements (42.7 %) have documentation comments.

Some symbols that are missing documentation: learning_input_image, learning_input_image.InputCameraMode, learning_input_image.InputCameraMode.InputCameraMode, learning_input_image.InputCameraType, learning_input_image.InputCameraType.InputCameraType.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:learning_input_image/learning_input_image.dart that imports:
  • package:learning_input_image/src/shared.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:learning_input_image/learning_input_image.dart that imports:
  • package:learning_input_image/src/shared.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:learning_input_image/learning_input_image.dart that imports:
  • package:learning_input_image/src/shared.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package not compatible with platform Web

Because:

  • package:learning_input_image/learning_input_image.dart that imports:
  • package:learning_input_image/src/input_image.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/src/input_camera.dart:65:28

   ╷
65 │     WidgetsBinding.instance?.addPostFrameCallback((_) async {
   │                            ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/input_camera.dart

INFO: The import of 'package:flutter/cupertino.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/src/button.dart:2:8

  ╷
2 │ import 'package:flutter/cupertino.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/button.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
camera ^0.9.4+5 0.9.8+1 0.11.0+1
flutter flutter 0.0.0 0.0.0
flutter_svg ^0.23.0+1 0.23.0+1 2.0.10+1
image_picker ^0.8.4+4 0.8.9 1.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
camera_android - 0.9.8+3 0.10.9+5
camera_avfoundation - 0.9.16 0.9.16
camera_platform_interface - 2.7.4 2.7.4
camera_web - 0.2.1+6 0.3.3
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
cross_file - 0.3.4+1 0.3.4+1
file_selector_linux - 0.9.2+1 0.9.2+1
file_selector_macos - 0.9.4 0.9.4
file_selector_platform_interface - 2.6.2 2.6.2
file_selector_windows - 0.9.3+1 0.9.3+1
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.1.0
image_picker_android - 0.8.12+3 0.8.12+3
image_picker_for_web - 2.2.0 3.0.4
image_picker_ios - 0.8.12 0.8.12
image_picker_linux - 0.2.1+1 0.2.1+1
image_picker_macos - 0.2.1+1 0.2.1+1
image_picker_platform_interface - 2.10.0 2.10.0
image_picker_windows - 0.2.1+1 0.2.1+1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
path_drawing - 0.5.1+1 1.0.1
path_parsing - 0.2.1 1.0.1
petitparser - 5.4.0 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
quiver - 3.2.1 3.2.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
xml - 5.4.1 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.9.4+5` on camera does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions camera to update the constraint.

The constraint `^0.23.0+1` on flutter_svg does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

3
likes
110
pub points
66%
popularity

Publisher

unverified uploader

Input image package to be used by other learning plugins.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

camera, flutter, flutter_svg, image_picker

More

Packages that depend on learning_input_image