keri 2.1.5 copy "keri: ^2.1.5" to clipboard
keri: ^2.1.5 copied to clipboard

Dart client for managing KERI based Identifiers on various platforms.

0
likes
120/ 160
pub points
0%
popularity

We analyzed this package 32 hours ago, and awarded it 120 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: EUPL-1.2.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

59 out of 876 API elements (6.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: bridge_generated, bridge_generated.Action, bridge_generated.Action.Action, bridge_generated.ActionRequired, bridge_generated.ActionRequired.ActionRequired.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:keri/keri.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:keri/keri.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:keri/keri.dart that declares support for platforms: Android, iOS, macOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/bridge_generated.freezed.dart:146:17

    ╷
146 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/bridge_generated.freezed.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/bridge_generated.freezed.dart:290:17

    ╷
290 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/bridge_generated.freezed.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.1 2.1.2 2.1.2
file ^6.0.0 6.1.4 7.0.0
flutter flutter 0.0.0 0.0.0
flutter_rust_bridge ^1.82.1 1.82.1 1.82.6
freezed ^2.3.2 2.5.2 2.5.3
freezed_annotation ^2.2.0 2.4.1 2.4.1
keri_android ^1.1.2 1.1.2 1.1.2
keri_ios ^0.2.3 0.2.3 0.2.3
keri_macos ^0.2.3 0.2.3 0.2.3
keri_platform_interface ^1.1.2 1.1.2 1.1.3
meta ^1.8.0 1.12.0 1.15.0
plugin_platform_interface ^2.1.3 2.1.8 2.1.8
uuid ^3.0.7 3.0.7 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 70.0.0
analyzer - 6.4.1 6.6.0
archive - 3.6.1 3.6.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build - 2.4.1 2.4.1
build_cli_annotations - 2.1.0 2.1.0
build_config - 1.1.1 1.1.1
build_daemon - 4.0.2 4.0.2
build_resolvers - 2.4.2 2.4.2
build_runner - 2.4.11 2.4.11
build_runner_core - 7.3.1 7.3.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
characters - 1.3.0 1.3.0
checked_yaml - 2.0.3 2.0.3
code_builder - 4.10.0 4.10.0
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
fixnum - 1.1.0 1.1.0
frontend_server_client - 4.0.0 4.0.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
http - 1.2.1 1.2.1
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
js - 0.6.7 0.7.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
mime - 1.0.5 1.0.5
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.3.0 1.3.0
puppeteer - 3.11.0 3.11.0
shelf - 1.4.1 1.4.1
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
sky_engine - 0.0.99 0.0.99
source_gen - 1.5.0 1.5.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.2
timing - 1.0.1 1.0.1
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.0.0` on file does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions file to update the constraint.

The constraint `^3.0.7` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.