k_debug_tools 1.0.3
k_debug_tools: ^1.0.3 copied to clipboard

KDebugTools is a powerful library for debugging Flutter applications.

5
likes
80 / 130
pub points
10 %
popularity

We analyzed this package on May 11, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 38 out of 181 API elements (21.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:k_debug_tools/k_debug_tools.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 59 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/appinfo/app_info.dart:27:27

   ╷
27 │   List<Widget> _widgets = List<Widget>();
   │                           ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/appinfo/app_info.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/dbview/db_controller.dart:39:24

   ╷
39 │     List<String> ret = List<String>();
   │                        ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/dbview/db_controller.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.132.0.133.1.2
convert^2.0.22.1.13.0.0
crypto^2.0.02.1.53.0.1
device_info^0.4.2+40.4.2+102.0.0
flutterflutter0.0.00.0.0
http_multi_server^2.2.02.2.03.0.1
http_parser^3.1.03.1.44.0.0
http_server^0.9.8+30.9.8+31.0.0
intl^0.16.00.16.10.17.0
mime^0.9.70.9.71.0.0
oktoast^2.3.22.3.23.0.0
package_info>=0.4.0+16 <2.0.00.4.3+42.0.0
path^1.7.01.8.01.8.0
path_provider^1.6.141.6.282.0.1
photo_manager^0.6.00.6.01.1.6
shared_preferences^0.5.7+30.5.12+42.0.5
shelf^0.7.90.7.91.1.2
shelf_proxy^0.1.0+70.1.0+71.0.0
shelf_router^0.7.20.7.41.0.0
shelf_static^0.2.80.2.9+21.0.0
shelf_web_socket^0.2.30.2.4+11.0.1
sqflite^1.3.11.3.2+42.0.0+3
stream_channel^2.0.02.1.02.1.0
uri^0.11.3+10.11.41.0.0
uuid^2.0.02.2.23.0.4
web_socket_channel^1.2.01.2.02.1.0
wifi_info_flutter^1.0.31.0.42.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.1.0
async-2.6.12.6.1
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
device_info_platform_interface-1.0.12.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.3
http_methods-1.1.01.1.0
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.3.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
pedantic-1.11.01.11.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
quiver-2.1.53.0.1
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-1.0.3+32.0.0+2
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
wifi_info_flutter_platform_interface-1.0.02.0.1
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 24 issues. Showing the first 2:

The constraint `^2.0.13` on archive does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions archive to update the constraint.

The constraint `^2.0.2` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.