json_serializable 4.1.0
json_serializable: ^4.1.0 copied to clipboard

Automatically generate code for converting to and from JSON by annotating Dart classes.

941
likes
100 / 130
pub points
99 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 57 out of 111 API elements (51.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:json_serializable/json_serializable.dart that imports:
  • package:json_serializable/src/json_serializable_generator.dart that imports:
  • package:json_serializable/src/type_helpers/uri_helper.dart that imports:
  • package:json_serializable/src/type_helpers/to_from_string.dart that imports:
  • package:json_serializable/src/type_helper.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/util/comment.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/fasta/ast_builder.dart that imports:
  • package:analyzer/src/dart/ast/ast_factory.dart that imports:
  • package:analyzer/src/dart/ast/ast.dart that imports:
  • package:analyzer/src/summary2/linked_unit_context.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/dart/resolver/scope.dart that imports:
  • package:analyzer/src/dart/element/scope.dart that imports:
  • package:analyzer/src/context/source.dart that imports:
  • package:analyzer/src/workspace/package_build.dart that imports:
  • package:analyzer/src/workspace/workspace.dart that imports:
  • package:analyzer/src/workspace/bazel.dart that imports:
  • package:analyzer/src/workspace/bazel_watcher.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.41.2 <2.0.01.4.01.4.0
build^2.0.02.0.02.0.0
build_config^0.4.40.4.70.4.7
collection^1.14.01.15.01.15.0
json_annotation>=4.0.1 <4.1.04.0.14.0.1
meta^1.3.01.3.01.3.0
path^1.8.01.8.01.8.0
source_gen^1.0.01.0.01.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-20.0.020.0.0
args-2.0.02.0.0
async-2.5.02.5.0
charcode-1.2.01.2.0
checked_yaml-2.0.12.0.1
cli_util-0.3.00.3.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
file-6.1.06.1.0
glob-2.0.12.0.1
package_config-2.0.02.0.0
pedantic-1.11.01.11.0
pubspec_parse-1.0.01.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • json_serializable that depends on:
  • build_config that doesn't opt in to null safety
For more information

Try running pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.15.4, Dart 2.12.2.

941
likes
100
pub points
99%
popularity

Publisher

google.dev

Automatically generate code for converting to and from JSON by annotating Dart classes.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

analyzer, build, build_config, collection, json_annotation, meta, path, source_gen

More

Packages that depend on json_serializable