json_serializable 3.5.0

Dart native

Automatically generate code for converting to and from JSON by annotating Dart classes.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  json_serializable: ^3.5.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:json_serializable/json_serializable.dart';
511
likes
100
pub points
98%
popularity

Publisher

google.dev

Automatically generate code for converting to and from JSON by annotating Dart classes.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

analyzer, build, build_config, json_annotation, meta, path, source_gen

More

Packages that depend on json_serializable