hermez_sdk 1.0.0+3 icon indicating copy to clipboard operation
hermez_sdk: ^1.0.0+3 copied to clipboard

Hermez Flutter SDK (https://hermez.io). This plugin provides a cross-platform tool (iOS, Android) to communicate with the Hermez Network.

2
likes
90/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 91 out of 700 API elements (13.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:hermez_sdk/hermez_sdk.dart that declares support for platforms: Android, iOS.

Package does not support platform Linux.

Because:

  • package:hermez_sdk/hermez_sdk.dart that declares support for platforms: Android, iOS.

Package does not support platform macOS.

Because:

  • package:hermez_sdk/hermez_sdk.dart that declares support for platforms: Android, iOS.

Package does not support platform Web.

Because:

  • package:hermez_sdk/hermez_sdk.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 22 issues. Showing the first 2:

ERROR: Subclasses of 'Struct' and 'Union' are backed by native memory, and can't be instantiated by a generative constructor.

lib/eddsa_babyjub.dart:39:33

   ╷
39 │     final Structs.Point point = Structs.Point.allocate(xPtr, yPtr);
   │                                 ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/eddsa_babyjub.dart

ERROR: Subclasses of 'Struct' and 'Union' are backed by native memory, and can't be instantiated by a generative constructor.

lib/eddsa_babyjub.dart:42:35

   ╷
42 │     final Structs.Signature sig = Structs.Signature.allocate(pointPtr, sPtr);
   │                                   ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/eddsa_babyjub.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bip39^1.0.61.0.61.0.6
ffi^1.1.21.2.12.0.1
flutterflutter0.0.00.0.0
hex^0.2.00.2.00.2.0
http^0.13.30.13.50.13.5
provider^5.0.05.0.06.0.4
shared_preferences^2.0.62.0.152.0.15
web3dart^2.1.32.5.12.5.1
web_socket_channel^2.1.02.2.02.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.16.01.17.0
convert-3.1.13.1.1
crypto-3.0.23.0.2
eip55-1.0.21.0.2
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.24.0.2
js-0.6.40.6.5
json_rpc_2-3.0.23.0.2
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
nested-1.0.01.0.0
path-1.8.21.8.2
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.0.72.1.3
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
pointycastle-3.6.23.6.2
process-4.2.44.2.4
sec-1.0.11.0.1
shared_preferences_android-2.0.142.0.14
shared_preferences_ios-2.1.12.1.1
shared_preferences_linux-2.1.12.1.1
shared_preferences_macos-2.0.42.0.4
shared_preferences_platform_interface-2.1.02.1.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.12.1.1
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stream_channel-2.1.12.1.1
stream_transform-2.1.02.1.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uuid-3.0.73.0.7
vector_math-2.1.22.1.4
win32-2.6.13.1.2
xdg_directories-0.2.0+20.2.0+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^1.1.2 on ffi does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint ^5.0.0 on provider does not support the stable version 6.0.0.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

2
likes
90
pub points
0%
popularity

Publisher

verified publisher iconhermez.io

Hermez Flutter SDK (https://hermez.io). This plugin provides a cross-platform tool (iOS, Android) to communicate with the Hermez Network.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

bip39, ffi, flutter, hex, http, provider, shared_preferences, web3dart, web_socket_channel

More

Packages that depend on hermez_sdk