gmsoft_pkg 0.1.9 copy "gmsoft_pkg: ^0.1.9" to clipboard
gmsoft_pkg: ^0.1.9 copied to clipboard

gmsoft_pkg flutter package project for erp.

1
likes
90/ 160
pub points
60%
popularity

We analyzed this package 11 hours ago, and awarded it 90 pub points (of a possible 160):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting gmsoft_pkg... Discovering libraries... Linking elements... Precaching local docs for 654453 elements... Initialized dartdoc with 1380 libraries Generating docs for library datepicker_widget.dart from package:gmsoft_pkg/datepicker_widget.dart... Generating docs for library popup_menu.dart from package:gmsoft_pkg/popup_menu.dart... Generating docs for library dashed_seperator.dart from package:gmsoft_pkg/dashed_seperator.dart... Generating docs for library complex_item_card.dart from package:gmsoft_pkg/complex_item_card.dart... Generating docs for library custom_floating_action_button_widget.dart from package:gmsoft_pkg/custom_floating_action_button_widget.dart... [31 more lines] ERR: The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. [5116 more lines]

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:gmsoft_pkg/file_picker_widget.dart that imports:
  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/linux/file_picker_linux.dart that imports:
  • package:file_picker/src/utils.dart that imports:
  • dart:io

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:gmsoft_pkg/file_picker_widget.dart that imports:
  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:gmsoft_pkg/file_picker_widget.dart that imports:
  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:gmsoft_pkg/file_picker_widget.dart that imports:
  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:gmsoft_pkg/file_picker_widget.dart that imports:
  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 60 issues. Showing the first 2:

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: DatePickerWidget.focusColor, DatePickerWidget.labeltext, DatePickerWidget.valuetext, DatePickerWidget.readonly, DatePickerWidget.enabled, DatePickerWidget.formaterPatern, DatePickerWidget.keyboardType, DatePickerWidget.validator, DatePickerWidget.inputFormatters, DatePickerWidget.controller, DatePickerWidget.inputDecoration

lib/datepicker_widget.dart:8:7

  ╷
8 │ class DatePickerWidget extends StatefulWidget {
  │       ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/datepicker_widget.dart

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: DetailsCard.key_, DetailsCard.value, DetailsCard.child, DetailsCard.rightchild, DetailsCard.minwidth, DetailsCard.iconKey, DetailsCard.iconValue

lib/details_card.dart:7:7

  ╷
7 │ class DetailsCard extends StatelessWidget {
  │       ^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/details_card.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
file_picker ^5.2.5 5.5.0 8.0.6
flutter flutter 0.0.0 0.0.0
flutter_colorpicker ^1.0.3 1.1.0 1.1.0
flutter_svg ^1.1.4 1.1.6 2.0.10+1
gap ^3.0.1 3.0.1 3.0.1
intl ^0.17.0 0.17.0 0.19.0
lottie ^2.3.0 2.7.0 3.1.2
rflutter_alert ^2.0.7 2.0.7 2.0.7
shared_preferences ^2.0.15 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.1 3.6.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_drawing - 1.0.1 1.0.1
path_parsing - 1.0.1 1.0.1
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 1.0.0
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^5.2.5` on file_picker does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions file_picker to update the constraint.

The constraint `^1.1.4` on flutter_svg does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
90
pub points
60%
popularity

Publisher

unverified uploader

gmsoft_pkg flutter package project for erp.

Documentation

API reference

License

unknown (license)

Dependencies

file_picker, flutter, flutter_colorpicker, flutter_svg, gap, intl, lottie, rflutter_alert, shared_preferences

More

Packages that depend on gmsoft_pkg