gits_strapi 1.0.1 copy "gits_strapi: ^1.0.1" to clipboard
gits_strapi: ^1.0.1 copied to clipboard

this library is used to facilitate integration with Strapi there are several main functions such as GET collection, single, and CRUD besides that we also provide several helpers to make it easier to use.

4
likes
130/ 160
pub points
2%
popularity

We analyzed this package 31 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

23 out of 236 API elements (9.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: gits_strapi, gits_strapi.AuthEntity, gits_strapi.AuthEntity.AuthEntity, gits_strapi.AuthEntity.jwt, gits_strapi.AuthEntity.user.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:gits_strapi/gits_strapi.dart that imports:
  • package:gits_strapi/src/gits_strapi.dart that imports:
  • package:gits_http/gits_http.dart that imports:
  • package:gits_http/src/gits_http.dart that imports:
  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_page.dart that imports:
  • package:gits_inspector/src/service/inspector_service.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:gits_strapi/gits_strapi.dart that imports:
  • package:gits_strapi/src/gits_strapi.dart that imports:
  • package:gits_http/gits_http.dart that imports:
  • package:gits_http/src/gits_http.dart that imports:
  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_page.dart that imports:
  • package:gits_inspector/src/service/inspector_service.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:gits_strapi/gits_strapi.dart that imports:
  • package:gits_strapi/src/gits_strapi.dart that imports:
  • package:gits_http/gits_http.dart that imports:
  • package:gits_http/src/gits_http.dart that imports:
  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/helper/shake_detector.dart that imports:
  • package:sensors_plus/sensors_plus.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:gits_strapi/gits_strapi.dart that imports:
  • package:gits_strapi/src/gits_strapi.dart that imports:
  • package:gits_http/gits_http.dart that imports:
  • package:gits_http/src/gits_http.dart that imports:
  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_page.dart that imports:
  • package:gits_inspector/src/service/inspector_service.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:gits_strapi/gits_strapi.dart that imports:
  • package:gits_strapi/src/gits_strapi.dart that imports:
  • package:gits_http/gits_http.dart that imports:
  • package:gits_http/src/gits_http.dart that imports:
  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/helper/local_notification.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications/src/notification_details.dart that imports:
  • package:flutter_local_notifications_linux/flutter_local_notifications_linux.dart that imports:
  • package:flutter_local_notifications_linux/src/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications_linux/src/notifications_manager.dart that imports:
  • package:flutter_local_notifications_linux/src/storage.dart that imports:
  • package:flutter_local_notifications_linux/src/platform_info.dart that imports:
  • package:xdg_directories/xdg_directories.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:gits_strapi/gits_strapi.dart that imports:
  • package:gits_strapi/src/gits_strapi.dart that imports:
  • package:gits_http/gits_http.dart that imports:
  • package:gits_http/src/gits_http.dart that imports:
  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/helper/local_notification.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications/src/notification_details.dart that imports:
  • package:flutter_local_notifications_linux/flutter_local_notifications_linux.dart that imports:
  • package:flutter_local_notifications_linux/src/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications_linux/src/notifications_manager.dart that imports:
  • package:flutter_local_notifications_linux/src/storage.dart that imports:
  • package:flutter_local_notifications_linux/src/platform_info.dart that imports:
  • package:xdg_directories/xdg_directories.dart that declares support for platforms: Linux.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
gits_http ^0.3.3 0.3.4 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
cross_file - 0.3.4+1 0.3.4+1
crypto - 3.0.3 3.0.3
dbus - 0.7.10 0.7.10
equatable - 2.0.5 2.0.5
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
flutter_local_notifications - 9.9.1 17.1.2
flutter_local_notifications_linux - 0.5.1 4.0.0+1
flutter_local_notifications_platform_interface - 5.0.0 7.1.0
flutter_web_plugins - 0.0.0 0.0.0
gits_inspector - 1.0.1 3.2.1
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.17.0 0.19.0
logger - 1.4.0 2.3.0
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.5 2.2.5
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
process - 4.2.4 5.0.2
sensors_plus - 1.4.1 5.0.1
sensors_plus_platform_interface - 1.2.0 1.2.0
sensors_plus_web - 1.1.2 1.1.2
share_plus - 4.5.3 9.0.0
share_plus_linux - 3.0.1 3.0.1
share_plus_macos - 3.0.1 3.0.1
share_plus_platform_interface - 3.4.0 4.0.0
share_plus_web - 3.1.0 3.1.0
share_plus_windows - 3.0.1 4.0.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sqflite - 2.3.3+1 2.3.3+1
sqflite_common - 2.5.4 2.5.4
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
timezone - 0.8.0 0.9.3
typed_data - 1.3.2 1.3.2
url_launcher - 6.3.0 6.3.0
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 0.2.0+3 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.3` on gits_http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions gits_http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

4
likes
130
pub points
2%
popularity

Publisher

verified publishergits.id

this library is used to facilitate integration with Strapi there are several main functions such as GET collection, single, and CRUD besides that we also provide several helpers to make it easier to use.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, gits_http

More

Packages that depend on gits_strapi