getxfire 0.3.1
getxfire: ^0.3.1 copied to clipboard

A Flutter Package that implemented firebase services with getx package.

40
likes
100/ 130
pub points
83%
popularity

We analyzed this package on Oct 20, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 29 out of 181 API elements (16.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:getxfire/getxfire.dart that declares support for platforms: Android, iOS, macOS, Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/converter_helper.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^2.2.22.5.32.5.3
firebase_analytics^8.1.18.3.38.3.3
firebase_auth^1.3.01.4.13.1.3
firebase_core^1.2.11.7.01.7.0
firebase_dynamic_links^2.0.52.0.102.0.10
firebase_storage^8.1.18.1.310.0.5
flutterflutter0.0.00.0.0
flutter_animated_dialog^2.0.12.0.12.0.1
flutter_spinkit^5.1.05.1.05.1.0
flutter_web_browser^0.15.00.15.00.15.0
flutter_web_pluginsflutter0.0.00.0.0
font_awesome_flutter^9.1.09.2.09.2.0
get^4.3.84.3.84.3.8
google_sign_in^5.0.75.1.15.1.1
image_cropper^1.4.11.4.11.4.1
image_picker^0.8.40.8.4+30.8.4+3
intl^0.17.00.17.00.17.0
lottie^1.1.01.2.11.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
cloud_firestore_platform_interface-5.4.25.4.2
cloud_firestore_web-2.4.32.4.3
collection-1.15.01.15.0
cross_file-0.3.1+50.3.1+5
crypto-3.0.13.0.1
firebase-9.0.29.0.2
firebase_analytics_platform_interface-2.0.12.0.1
firebase_analytics_web-0.3.0+10.3.0+1
firebase_auth_platform_interface-4.3.16.1.1
firebase_auth_web-1.3.13.1.2
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
firebase_storage_platform_interface-2.1.24.0.3
firebase_storage_web-1.1.23.0.3
flutter_plugin_android_lifecycle-2.0.42.0.4
google_sign_in_platform_interface-2.1.02.1.0
google_sign_in_web-0.10.0+30.10.0+3
http-0.13.40.13.4
http_parser-4.0.04.0.0
image_picker_for_web-2.1.42.1.4
image_picker_platform_interface-2.4.12.4.1
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
quiver-3.0.1+13.0.1+1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.3.0` on firebase_auth does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

The constraint `^8.1.1` on firebase_storage does not support the stable version `9.0.0`.

Try running dart pub upgrade --major-versions firebase_storage to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.