flutterfire_ui 0.4.2 icon indicating copy to clipboard operation
flutterfire_ui: ^0.4.2 copied to clipboard

UI library built on top of firebase services

357
likes
80/ 130
pub points
97%
popularity

We analyzed this package 4 hours ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 167 out of 1096 API elements (15.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:flutterfire_ui/auth.dart that imports:
  • package:flutterfire_ui/src/auth/configs/oauth_provider_configuration.dart that imports:
  • package:flutterfire_ui/src/auth/flows/oauth_flow.dart that imports:
  • package:flutterfire_ui/src/auth/oauth/oauth_providers.dart that imports:
  • package:desktop_webview_auth/desktop_webview_auth.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:flutterfire_ui/auth.dart that imports:
  • package:flutterfire_ui/src/auth/configs/oauth_provider_configuration.dart that imports:
  • package:flutterfire_ui/src/auth/flows/oauth_flow.dart that imports:
  • package:flutterfire_ui/src/auth/oauth/oauth_providers.dart that imports:
  • package:desktop_webview_auth/desktop_webview_auth.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Windows`.

Because:

  • package:flutterfire_ui/auth.dart that imports:
  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:flutterfire_ui/auth.dart that imports:
  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutterfire_ui/auth.dart that imports:
  • package:flutterfire_ui/src/auth/configs/email_link_provider_configuration.dart that imports:
  • package:firebase_dynamic_links/firebase_dynamic_links.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutterfire_ui/auth.dart that imports:
  • package:flutterfire_ui/src/auth/configs/email_link_provider_configuration.dart that imports:
  • package:firebase_dynamic_links/firebase_dynamic_links.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^3.1.183.1.183.1.18
collection^1.15.01.16.01.16.0
crypto^3.0.13.0.23.0.2
desktop_webview_auth^0.0.50.0.90.0.9
email_validator^2.0.12.0.12.0.1
firebase_auth^3.3.203.3.203.3.20
firebase_core^1.10.21.18.01.18.0
firebase_database^9.0.169.0.169.0.16
firebase_dynamic_links^4.2.64.2.64.2.6
flutterflutter0.0.00.0.0
flutter_facebook_auth^4.0.14.3.4+24.3.4+2
flutter_localizationsflutter0.0.00.0.0
flutter_svg^1.0.01.1.11.1.1
google_sign_in^5.2.15.3.35.3.3
sign_in_with_apple^3.3.03.3.04.0.0
twitter_login^4.2.24.2.34.2.3
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
characters-1.2.01.2.1
clock-1.1.01.1.1
cloud_firestore_platform_interface-5.5.85.5.8
cloud_firestore_web-2.6.172.6.17
firebase_auth_platform_interface-6.2.86.2.8
firebase_auth_web-3.3.173.3.17
firebase_core_platform_interface-4.4.14.4.1
firebase_core_web-1.6.51.6.5
firebase_database_platform_interface-0.2.1+80.2.1+8
firebase_database_web-0.2.0+150.2.0+15
firebase_dynamic_links_platform_interface-0.2.3+40.2.3+4
flutter_facebook_auth_platform_interface-3.1.24.0.0
flutter_facebook_auth_web-3.1.24.0.0
flutter_web_plugins-0.0.00.0.0
google_sign_in_android-5.2.85.2.8
google_sign_in_ios-5.3.15.3.1
google_sign_in_platform_interface-2.2.02.2.0
google_sign_in_web-0.10.1+30.10.1+3
http-0.13.40.13.4
http_parser-4.0.14.0.1
intl-0.17.00.17.0
js-0.6.40.6.4
matcher-0.12.120.12.12
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
path-1.8.11.8.2
path_drawing-1.0.01.0.0
path_parsing-1.0.01.0.0
petitparser-5.0.05.0.0
plugin_platform_interface-2.1.22.1.2
quiver-3.1.03.1.0
sign_in_with_apple_platform_interface-1.0.01.0.0
sign_in_with_apple_web-1.0.11.0.1
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
xml-6.1.06.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.3.0` on sign_in_with_apple does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions sign_in_with_apple to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.