flutter_ume_kit_designer_check 0.0.2 copy "flutter_ume_kit_designer_check: ^0.0.2" to clipboard
flutter_ume_kit_designer_check: ^0.0.2 copied to clipboard

UI check tool for designer.

0
likes
95/ 140
pub points
31%
popularity

We analyzed this package 2 days ago, and awarded it 95 pub points (of a possible 140):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/cfug/flutter_ume_kit was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutter_ume_kit_designer_check,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

3 out of 17 API elements (17.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: flutter_ume_kit_designer_check, flutter_ume_kit_designer_check.DesignerCheck, flutter_ume_kit_designer_check.DesignerCheck.DesignerCheck, flutter_ume_kit_designer_check.DesignerCheck.buildWidget, flutter_ume_kit_designer_check.DesignerCheck.displayName.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_ume_kit_designer_check/flutter_ume_kit_designer_check.dart that imports:
  • package:flutter_ume_kit_designer_check/src/designer_check.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_ume >=0.3.0 <0.4.0 0.3.0+1 1.1.2
image_picker ^0.8.5 0.8.9 1.1.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
cross_file - 0.3.4+1 0.3.4+1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
file_selector_linux - 0.9.2+1 0.9.2+1
file_selector_macos - 0.9.4 0.9.4
file_selector_platform_interface - 2.6.2 2.6.2
file_selector_windows - 0.9.3+1 0.9.3+1
flutter_localizations - 0.0.0 0.0.0
flutter_plugin_android_lifecycle - 2.0.19 2.0.19
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
image_picker_android - 0.8.12+1 0.8.12+1
image_picker_for_web - 2.2.0 3.0.4
image_picker_ios - 0.8.11+2 0.8.11+2
image_picker_linux - 0.2.1+1 0.2.1+1
image_picker_macos - 0.2.1+1 0.2.1+1
image_picker_platform_interface - 2.10.0 2.10.0
image_picker_windows - 0.2.1+1 0.2.1+1
intl - 0.19.0 0.19.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences - 2.2.3 2.2.3
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 7.5.0 14.2.2
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.3.0 <0.4.0` on flutter_ume does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions flutter_ume to update the constraint.

The constraint `^0.8.5` on image_picker does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions image_picker to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.