flutter_toolbox 6.3.1
flutter_toolbox: ^6.3.1 copied to clipboard

Common flutter widgets and helper methods.

1
likes
60/ 130
pub points
50%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 136 out of 366 API elements (37.2 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `iOS`.

Because:

  • package:flutter_toolbox/flutter_toolbox.dart that declares support for platforms: Android.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/generated/intl/messages_all.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/generated/intl/messages_ar.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^2.5.02.5.13.1.0
chopper2^3.0.73.0.73.0.7
connectivity_plus^0.8.10.8.11.1.0
flushbar^1.10.41.10.41.10.4
flutterflutter0.0.00.0.0
flutter_cache_manager^2.1.12.1.23.1.2
flutter_image_compress^0.7.00.7.01.1.0
http>=0.12.2 <=0.13.0-nullsafety.00.12.20.13.3
image_picker^0.6.7+220.6.7+220.8.4+2
intl>=0.15.3 <=0.17.0-nullsafety.20.16.10.17.0
json_annotation^3.1.13.1.14.1.0
oktoast^2.3.22.3.23.1.3+1
path^1.7.01.8.01.8.0
path_provider^1.6.271.6.282.0.5
photo_view^0.10.30.10.30.12.0
provider^4.3.34.3.36.0.0
shared_preferences^0.5.12+40.5.12+42.0.8
stack_trace^1.9.61.10.01.10.0
url_launcher^5.7.105.7.106.0.11
uuid^2.2.22.2.23.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.3.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
connectivity_plus_linux-0.3.11.1.0
connectivity_plus_macos-0.4.11.1.0
connectivity_plus_platform_interface-0.4.11.1.0
connectivity_plus_web-0.6.11.1.0+1
connectivity_plus_windows-0.1.11.1.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
dbus-0.1.20.6.3
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.5.00.6.0
flutter_plugin_android_lifecycle-1.0.112.0.3
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
image-2.1.193.0.5
image_picker_platform_interface-1.1.62.4.1
js-0.6.30.6.3
logging-0.11.41.0.2
meta-1.7.01.7.0
nested-1.0.01.0.0
octo_image-0.3.01.0.0+1
path_provider_linux-0.0.1+22.1.0
path_provider_macos-0.0.4+82.0.2
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
pedantic-1.11.11.11.1
petitparser-3.1.04.3.0
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.1
process-4.2.34.2.3
rxdart-0.25.00.27.2
shared_preferences_linux-0.0.2+42.0.2
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.2
shared_preferences_windows-0.0.2+32.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.4
url_launcher_windows-0.0.1+32.0.2
vector_math-2.1.02.1.1
win32-2.2.92.2.9
xdg_directories-0.1.20.2.0
xml-4.5.15.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 15 issues. Showing the first 2:

The constraint `^2.5.0` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^0.8.1` on connectivity_plus does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.