flutter_support_chat 1.2.0 icon indicating copy to clipboard operation
flutter_support_chat: ^1.2.0 copied to clipboard

Flutter package to implement a firestore chat between customer and product support

7
likes
140/ 140
pub points
48%
popularity

We analyzed this package 4 days ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 14 API elements (85.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:flutter_support_chat/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/overview.dart that imports:
  • package:flutter_support_chat/src/new_case.dart that imports:
  • package:flutter_support_chat/src/model/message.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.

Package does not support platform Linux.

Because:

  • package:flutter_support_chat/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/overview.dart that imports:
  • package:flutter_support_chat/src/new_case.dart that imports:
  • package:flutter_support_chat/src/model/message.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.

Package does not support platform Web.

Because:

  • package:flutter_support_chat/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/overview.dart that imports:
  • package:flutter_support_chat/src/new_case.dart that imports:
  • package:adaptive_dialog/adaptive_dialog.dart that imports:
  • package:adaptive_dialog/src/text_input_dialog/show_text_input_dialog.dart that imports:
  • package:adaptive_dialog/src/text_input_dialog/macos_text_input_dialog.dart that imports:
  • package:macos_ui/macos_ui.dart that declares support for platforms: macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform Android.

Because:

  • package:flutter_support_chat/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/overview.dart that imports:
  • package:flutter_support_chat/src/new_case.dart that imports:
  • package:adaptive_dialog/adaptive_dialog.dart that imports:
  • package:adaptive_dialog/src/text_input_dialog/show_text_input_dialog.dart that imports:
  • package:adaptive_dialog/src/text_input_dialog/macos_text_input_dialog.dart that imports:
  • package:macos_ui/macos_ui.dart that declares support for platforms: macOS.

Package does not support platform iOS.

Because:

  • package:flutter_support_chat/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/overview.dart that imports:
  • package:flutter_support_chat/src/new_case.dart that imports:
  • package:adaptive_dialog/adaptive_dialog.dart that imports:
  • package:adaptive_dialog/src/text_input_dialog/show_text_input_dialog.dart that imports:
  • package:adaptive_dialog/src/text_input_dialog/macos_text_input_dialog.dart that imports:
  • package:macos_ui/macos_ui.dart that declares support for platforms: macOS.

Package does not support platform macOS.

Because:

  • package:flutter_support_chat/flutter_support_chat.dart that imports:
  • package:flutter_support_chat/src/flutter_support_chat.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
adaptive_dialog>=1.6.0 <2.0.01.8.0+11.8.0+1
cloud_firestore>=2.2.0 <5.0.04.1.04.1.0
device_info_plus>=7.0.0 <9.0.08.0.08.0.0
firebase_core>=1.2.0 <3.0.02.3.02.3.0
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_flutterfire_internals-1.0.91.0.9
animations-2.0.72.0.7
async-2.9.02.10.0
boolean_selector-2.1.02.1.1
characters-1.2.11.2.1
clock-1.1.11.1.1
cloud_firestore_platform_interface-5.9.05.9.0
cloud_firestore_web-3.1.03.1.0
collection-1.16.01.17.0
device_info_plus_platform_interface-7.0.07.0.0
dynamic_color-1.5.41.5.4
fake_async-1.3.11.3.1
ffi-2.0.12.0.1
file-6.1.46.1.4
firebase_core_platform_interface-4.5.24.5.2
firebase_core_web-2.0.12.0.1
flutter_test-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
intersperse-2.0.02.0.0
js-0.6.40.6.5
macos_ui-1.7.51.7.5
matcher-0.12.120.12.13
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.21.8.2
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.01.9.1
stack_trace-1.10.01.11.0
stream_channel-2.1.02.1.1
string_scanner-1.1.11.2.0
term_glyph-1.2.11.2.1
test_api-0.4.120.4.16
vector_math-2.1.22.1.4
win32-3.1.23.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

7
likes
140
pub points
48%
popularity

Publisher

verified publisher iconcedtegapps.de

Flutter package to implement a firestore chat between customer and product support

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

adaptive_dialog, cloud_firestore, device_info_plus, firebase_core, flutter

More

Packages that depend on flutter_support_chat