flutter_robusta_cli 0.2.0-dev.1 copy "flutter_robusta_cli: ^0.2.0-dev.1" to clipboard
flutter_robusta_cli: ^0.2.0-dev.1 copied to clipboard

Robusta CLI help to create new projects and generate codes for your apps.

0
likes
130/ 160
pub points
0%
popularity

We analyzed this package 44 hours ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5 out of 9 API elements (55.6 %) have documentation comments.

Some symbols that are missing documentation: robusta_new_project_bundle, robusta_new_project_bundle.robustaNewProjectBundle, version.g, version.g.cliVersion.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:flutter_robusta_cli/flutter_robusta_cli.dart that imports:
  • package:flutter_robusta_cli/src/extension.dart that imports:
  • package:flutter_robusta_cli/src/self_update_command.dart that imports:
  • package:interact/interact.dart that imports:
  • package:interact/src/spinner.dart that imports:
  • package:interact/src/utils/utils.dart that imports:
  • package:interact/src/framework/framework.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:flutter_robusta_cli/flutter_robusta_cli.dart that imports:
  • package:flutter_robusta_cli/src/extension.dart that imports:
  • package:flutter_robusta_cli/src/self_update_command.dart that imports:
  • package:interact/interact.dart that imports:
  • package:interact/src/spinner.dart that imports:
  • package:interact/src/utils/utils.dart that imports:
  • package:interact/src/framework/framework.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_robusta_cli/flutter_robusta_cli.dart that imports:
  • package:flutter_robusta_cli/src/extension.dart that imports:
  • package:flutter_robusta_cli/src/self_update_command.dart that imports:
  • package:interact/interact.dart that imports:
  • package:interact/src/spinner.dart that imports:
  • package:interact/src/utils/utils.dart that imports:
  • package:interact/src/framework/framework.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:flutter_robusta_cli/flutter_robusta_cli.dart that imports:
  • package:flutter_robusta_cli/src/extension.dart that imports:
  • package:flutter_robusta_cli/src/self_update_command.dart that imports:
  • package:interact/interact.dart that imports:
  • package:interact/src/spinner.dart that imports:
  • package:interact/src/utils/utils.dart that imports:
  • package:interact/src/framework/framework.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:flutter_robusta_cli/flutter_robusta_cli.dart that imports:
  • package:flutter_robusta_cli/src/extension.dart that imports:
  • package:flutter_robusta_cli/src/self_update_command.dart that imports:
  • package:interact/interact.dart that imports:
  • package:interact/src/spinner.dart that imports:
  • package:interact/src/utils/utils.dart that imports:
  • package:interact/src/framework/framework.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/mason_bricks/robusta_new_project_bundle.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.4.0 2.5.0 2.5.0
interact ^2.2.0 2.2.0 2.2.0
logger ^1.3.0 1.4.0 2.3.0
mason ^0.1.0-dev.49 0.1.0-dev.57 0.1.0-dev.57
pub_updater ^0.3.0 0.3.1 0.4.0
riverpod ^2.3.0 2.5.1 2.5.1
robusta_runner ^0.2.0 0.2.0+1 0.2.0+1
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.1 3.6.1
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
checked_yaml - 2.0.3 2.0.3
clock - 1.1.1 1.1.1
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_console - 1.2.0 4.1.0
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.18.1 0.19.0
io - 1.0.4 1.0.4
json_annotation - 4.9.0 4.9.0
mason_logger - 0.2.15 0.2.15
meta - 1.15.0 1.15.0
mustache_template - 2.0.0 2.0.0
path - 1.9.0 1.9.0
platform - 3.1.5 3.1.5
pool - 1.5.1 1.5.1
process - 4.2.4 5.0.2
pub_semver - 2.1.4 2.1.4
robusta_events - 0.2.1 0.2.1
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
state_notifier - 1.0.0 1.0.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tint - 2.0.1 2.0.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.3.0` on logger does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

The constraint `^0.3.0` on pub_updater does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions pub_updater to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

0
likes
130
pub points
0%
popularity

Publisher

unverified uploader

Robusta CLI help to create new projects and generate codes for your apps.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, interact, logger, mason, pub_updater, riverpod, robusta_runner

More

Packages that depend on flutter_robusta_cli