flutter_google_maps_widget_cluster_markers 0.0.1+1 copy "flutter_google_maps_widget_cluster_markers: ^0.0.1+1" to clipboard
flutter_google_maps_widget_cluster_markers: ^0.0.1+1 copied to clipboard

Flutter package to enable clustering of location markers on Google Maps using widgets specific to each location..

8
likes
70/ 140
pub points
50%
popularity

We analyzed this package 7 days ago, and awarded it 70 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

24 out of 30 API elements (80.0 %) have documentation comments.

Some symbols that are missing documentation: flutter_google_maps_widget_cluster_markers, flutter_google_maps_widget_cluster_markers.Place, flutter_google_maps_widget_cluster_markers.Place.Place, flutter_google_maps_widget_cluster_markers.Place.geohash, flutter_google_maps_widget_cluster_markers.Place.getLatLngId.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_google_maps_widget_cluster_markers/flutter_google_maps_widget_cluster_markers.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:flutter_google_maps_widget_cluster_markers/flutter_google_maps_widget_cluster_markers.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutter_google_maps_widget_cluster_markers/flutter_google_maps_widget_cluster_markers.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:flutter_google_maps_widget_cluster_markers/flutter_google_maps_widget_cluster_markers.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `iOS`.

Because:

  • package:flutter_google_maps_widget_cluster_markers/flutter_google_maps_widget_cluster_markers.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

ERROR: The argument type 'Future

lib/src/state/map_state.dart:268:22

    ╷
268 │       markerBuilder: markerBuilder,
    │                      ^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/state/map_state.dart

ERROR: The body might complete normally, causing 'null' to be returned, but the return type, 'FutureOr

lib/src/utils/boundary_key_to_bitmap.dart:40:35

   ╷
40 │       AssertionError(): (e) async {
   │                                   ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/utils/boundary_key_to_bitmap.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
after_layout ^1.2.0 1.2.0 1.2.0
collection ^1.16.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
flutter_dev_utils ^0.0.1+2 0.0.3 0.0.3
google_maps_cluster_manager ^3.0.0+1 3.1.0 3.1.0
google_maps_flutter ^2.1.1 2.6.1 2.6.1
logger ^1.1.0 1.4.0 2.3.0
provider ^6.0.2 6.1.2 6.1.2
tuple ^2.0.0 2.0.2 2.0.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
csslib - 1.0.0 1.0.0
flutter_plugin_android_lifecycle - 2.0.19 2.0.19
flutter_web_plugins - 0.0.0 0.0.0
google_maps - 7.1.0 7.1.0
google_maps_flutter_android - 2.8.0 2.8.0
google_maps_flutter_ios - 2.6.0 2.6.0
google_maps_flutter_platform_interface - 2.6.0 2.6.0
google_maps_flutter_web - 0.5.7 0.5.7
html - 0.15.4 0.15.4
js - 0.6.7 0.7.1
js_wrapping - 0.7.4 0.7.4
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sanitize_html - 2.1.0 2.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_transform - 2.1.0 2.1.0
term_glyph - 1.2.1 1.2.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.0` on logger does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

8
likes
70
pub points
50%
popularity

Publisher

verified publisherkek.technology

Flutter package to enable clustering of location markers on Google Maps using widgets specific to each location..

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

after_layout, collection, flutter, flutter_dev_utils, google_maps_cluster_manager, google_maps_flutter, logger, provider, tuple

More

Packages that depend on flutter_google_maps_widget_cluster_markers